Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008461 [DCSS] Bug Report trivial always 2014-04-28 23:39 2014-06-01 06:16
Reporter rchandra View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status closed   Product Branch 0.15 ancient branch
Summary 0008461: porridge isn't food
Description When searching for "food" with ctrl-F, rations, fruit, etc. appear but potions of porridge do not. This is fixable in the rcfile (autoinscribe += porridge:food) but it should probably show by default.

Additional Information
Tags No tags attached.
Attached Files ? file icon 8461_porridge_is_food.patch [^] (2,609 bytes) 2014-04-29 09:32 [Show Content]
? file icon 8461_porridge_is_food_fixed1.patch [^] (2,640 bytes) 2014-04-29 09:48 [Show Content]

- Relationships

-  Notes
(0025953)
qoala (reporter)
2014-04-29 09:37

oops. Disregard the patch I just uploaded.

If a food-class item is preferred food, it adds "{food}" to the stash search list twice. Doesn't break anything as far as I know, but does look odd on the "Stash search prefixes" list.
(0025954)
qoala (reporter)
2014-04-29 09:55

Okay, "fixed1" should be used instead of the first patch I uploaded.

I've added a check to mark items as food if they are potions and crawl considers them "preferred food" for the player. This will currently be porridge for most races and blood for vampires. Vampires will probably want to continue searching for "blood" if they search for such at all, because {food} still finds permafood by class name.

The check is applied to the lua for generating stash annotations as well as the item_prefix. |amethyst suggested that we were considering merging those two lists, but I missed any prior discussion so wasn't going to try undertaking that yet.

Still refamiliarizing myself with the code base, so I might've missed edge cases in how item prefices are used.
(0025975)
MarvinPA (developer)
2014-04-30 03:51

Pushed, thanks for the patch.

- Issue History
Date Modified Username Field Change
2014-04-28 23:39 rchandra New Issue
2014-04-29 09:32 qoala File Added: 8461_porridge_is_food.patch
2014-04-29 09:37 qoala Note Added: 0025953
2014-04-29 09:48 qoala File Added: 8461_porridge_is_food_fixed1.patch
2014-04-29 09:55 qoala Note Added: 0025954
2014-04-30 03:51 MarvinPA Note Added: 0025975
2014-04-30 03:51 MarvinPA Status new => resolved
2014-04-30 03:51 MarvinPA Fixed in Branch => 0.15 development branch
2014-04-30 03:51 MarvinPA Resolution open => done
2014-04-30 03:51 MarvinPA Assigned To => MarvinPA
2014-06-01 06:16 rchandra Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker