Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007662 [DCSS] Bug Report minor have not tried 2013-10-25 23:03 2013-10-26 01:07
Reporter Whales View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0007662: Inescapable Volcano entrance vault
Description A Volcano entrance vault consists of the portal to the volcano, blocked off from the rest of the level by lava. If I didn't have a scroll of teleport in the save below, I would have been stuck and would eventually starve.

http://crawl.akrasiac.org/saves/whales2-crawl-git-fd018d8dad-131025-1702.tar.bz2 [^]
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0005150resolvedMarvinPA A bailey that requires levitation to access sometimes does not spawn the potions of levitation required. 

-  Notes
(0024246)
neil (administrator)
2013-10-25 23:26

The problem isn't trapping the player: the part of the vault behind the lava is no_rtele_into, so you'll only get there through deliberate action, so you should plan to have a way out (and, assuming you know that volcanoes are full of fire, that shouldn't be a teleport scroll that you take into the volcano with you).

The real problem is that the entrance prohibits access to those who don't happen to be carrying a means of flight, digging, or controlled blinking. There is a Bailey that is even worse in this respect, because you don't discover the problem until after entering the portal (0005150).
(0024248)
MarvinPA (developer)
2013-10-26 01:07

Not a bug, but changed anyway to always generate a clear path to the volcano.

- Issue History
Date Modified Username Field Change
2013-10-25 23:03 Whales New Issue
2013-10-25 23:26 neil Note Added: 0024246
2013-10-25 23:27 neil Relationship added related to 0005150
2013-10-26 01:07 MarvinPA Note Added: 0024248
2013-10-26 01:07 MarvinPA Status new => resolved
2013-10-26 01:07 MarvinPA Fixed in Branch => 0.14 development branch
2013-10-26 01:07 MarvinPA Resolution open => done
2013-10-26 01:07 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker