Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007436 [DCSS] Source Cleanup minor N/A 2013-08-07 00:20 2013-12-07 17:37
Reporter cjo View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007436: Remove outdated code relating to butchering
Description Remove outdated code relating to unarmed butchering with gloves on.

Now that all players have a butchering knife, there is no reason for unarmed players to remove gloves in order to butcher, so code relating to that can be removed.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Do-not-take-gloves-off-to-butcher.patch [^] (6,154 bytes) 2013-08-07 00:20 [Show Content]
? file icon 0001-Remove-obsolete-butchering-code.patch [^] (26,310 bytes) 2013-08-07 23:54 [Show Content]
? file icon 0001-Allow-unarmed-butchering-remove-hypothetical-knife.patch [^] (9,634 bytes) 2013-08-09 00:49 [Show Content]
? file icon combined-butchering-fixes.patch [^] (50,620 bytes) 2013-08-10 06:19 [Show Content]

- Relationships
related to 0007382closedneil Raging Bat Crash 

-  Notes
(0023671)
cjo (reporter)
2013-08-07 23:55

I added another patch, which removes obsolete code related to switching weapons. Now that players can butcher with blunt weapons, that code is not needed.
(0023675)
MarvinPA (developer)
2013-08-08 14:10

Updated title.
(0023686)
cjo (reporter)
2013-08-08 19:00

MarvinPA, thanks for changing the name. In case it affects anyone's plans for reviewing this, I'm going to work on one more patch to pull out a few more bits of code. I'll be uploading it later today.
(0023689)
cjo (reporter)
2013-08-09 00:49

This is the last of what I have planned. Each patch should be applied over the prior one. I'll leave off here, except to address any faults people find when reviewing these.
(0023698)
neil (administrator)
2013-08-10 06:17
edited on: 2013-08-10 06:24

I rebased the patches to latest trunk (there were a few conflicts), removed one trailing whitespace in the second patch, and added a fourth patch to remove the last vestiges of ATTR_WEAPON_SWAP_INTERRUPTED. These are concatenated in the uploaded combined-butchering-fixes.patch .

The removal of handle_interrupted_swap() in the second patch does mean that, if the player was wielding a non-weapon and then changed into a non-wielding form, they won't be asked whether they want to change back when the form ends (they'll be empty-handed; if they had been wielding a weapon instead, it would have unmelded equipped). Probably the solution is to just remove the special case in _remove_equipment that makes non-weapons unequip rather than melding.

(0024630)
MarvinPA (developer)
2013-12-07 17:37

Oh oops, I independently cleaned up this code and forgot about these patches. ATTR_WEAPON_SWAP_INTERRUPTED and handle_interrupted_swap() still exist - I think one place they're (sort of) relevant is when a holy weapon falls away when casting lichform, presumably having it meld wouldn't really work there since you need to be able to wield another different weapon?

- Issue History
Date Modified Username Field Change
2013-08-07 00:20 cjo New Issue
2013-08-07 00:20 cjo File Added: 0001-Do-not-take-gloves-off-to-butcher.patch
2013-08-07 23:54 cjo File Added: 0001-Remove-obsolete-butchering-code.patch
2013-08-07 23:55 cjo Note Added: 0023671
2013-08-08 14:10 MarvinPA Note Added: 0023675
2013-08-08 14:10 MarvinPA Summary Remove outdated code relating to unarmed butchering with gloves on => Remove outdated code relating to butchering
2013-08-08 19:00 cjo Note Added: 0023686
2013-08-09 00:49 cjo File Added: 0001-Allow-unarmed-butchering-remove-hypothetical-knife.patch
2013-08-09 00:49 cjo Note Added: 0023689
2013-08-10 05:16 neil Relationship added related to 0007382
2013-08-10 06:17 neil Note Added: 0023698
2013-08-10 06:19 neil File Added: combined-butchering-fixes.patch
2013-08-10 06:23 neil Note Edited: 0023698
2013-08-10 06:24 neil Note Edited: 0023698
2013-12-07 17:37 MarvinPA Note Added: 0024630
2013-12-07 17:37 MarvinPA Status new => resolved
2013-12-07 17:37 MarvinPA Fixed in Branch => 0.14 development branch
2013-12-07 17:37 MarvinPA Resolution open => done
2013-12-07 17:37 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker