Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005598 [DCSS] Bug Report minor have not tried 2012-04-26 01:32 2014-03-27 06:19
Reporter KiloByte View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0005598: sickly siren can starve you
Description In sewer_sea, if you're a melee char, the sickly siren will mesmerize you then sit in the water beyond your reach -- or rather, beyond the range of non-polearms.

If you have a spell or a polearm, you can kill her without any challenge at all (not good!). If you have only a melee weapon, and didn't happen to get an attack wand yet (likely for Sewers), you'll be stuck there until you starve.

Occasionally, the siren comes forward for a single turn, but that's enough for just a single blow. If mesmerisation times out, you'll get pulled back after 1-2 steps.


In other words: either this monster gives xp for free, or makes players stuck unless they happen to have resources that are likely to be not available yet.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0017874)
jeffqyzt (reporter)
2012-04-26 14:35

I thought that's what the guaranteed potions of levitation and scrolls of teleportation were for? Both appear in the vault prior to where you'd see the siren, unless you teleport prior...
(0017875)
dolorous (updater)
2012-04-26 19:29

According to the code in player::beholders_check_noise(), a loud enough noise (e.g. a scroll of noise; I remember that shouting used to work but it no longer seems to) will break mesmerization, but it's not documented anywhere that I can see.
(0017889)
evilmike (developer)
2012-04-27 00:20

Yeah, scrolls of noise will break it, along with particularly loud spells (lightning bolt and fireball work nicely, since you can get those from wands).

I think the problem here is that it's possible to get stuck, though. Even if you give the player escape options, its possible they will use them badly, or not pick them up. In that case, they will starve to death (very boring and tedious), or on a mummy/vampire, be forced to quit.

On IRC I proposed giving the siren a polearm (a spear maybe) so she can attack you. This way you should actually die of normal causes. This is the evil solution, though. The question remains: is current siren behaviour a good thing?
(0017891)
KiloByte (manager)
2012-04-27 00:49

Sirens don't have any means of killing you this way -- they sit in the water two squares from shallows and do nothing. Giving them all a polearm would partially deal with the immediate problem, but would be pretty unthematic: sirens were said to lure people into water, not to magically bind them on the shore and poke from safety.
(0017892)
ion_frigate (reporter)
2012-04-27 03:23

IMO the problem is sirens in general, not this one particular one. Sirens are supposed to lure people into the water. So why don't they do that? They lure you to the edge of deep water, where you will sit until you break the mesmerization, teleport away, or one of you dies. This is crappy behavior in general.

How about after a a random but non-trivial amount of time mesmerized (say 25-45 turns) by a siren, you *do* go into the deep water? You have the usual chance to scramble free, and if you do, the shock of getting drenched breaks the mesmerization - and makes you immune to subsequent mesmerization for a good long time, although possibly just mesermization from that particular siren (to prevent abuse in Shoals). This would be considerably less evil than just giving the siren a polearm, while still avoiding the problem of being stuck mesmerized by that siren forever.
(0017901)
jeffqyzt (reporter)
2012-04-27 15:40

Foobar the Adventurer, killed by drowning in deep water
   ...lured to their doom by a siren.

Would definitely spice up the morgue lists :-) I'm in favor of this.
(0017946)
Kyrris (reporter)
2012-05-02 09:18

If it is made able to kill you, the MR/XL check for mesmerize could stand a review.
(0017947)
roctavian (developer)
2012-05-02 09:57

I think an even shorter amount of time than 25 turns would be appropriate, provided a warning like "You are being lured dangerously out of your depth!" or similar a few rounds before it kills you.
(0025729)
MarvinPA (developer)
2014-03-27 06:19

Sirens don't try and stay out of reach now.

- Issue History
Date Modified Username Field Change
2012-04-26 01:32 KiloByte New Issue
2012-04-26 14:35 jeffqyzt Note Added: 0017874
2012-04-26 19:29 dolorous Note Added: 0017875
2012-04-27 00:20 evilmike Note Added: 0017889
2012-04-27 00:49 KiloByte Note Added: 0017891
2012-04-27 03:23 ion_frigate Note Added: 0017892
2012-04-27 15:40 jeffqyzt Note Added: 0017901
2012-05-02 09:18 Kyrris Note Added: 0017946
2012-05-02 09:57 roctavian Note Added: 0017947
2013-03-26 21:06 mumra Issue Monitored: mumra
2014-03-27 06:19 MarvinPA Note Added: 0025729
2014-03-27 06:19 MarvinPA Status new => resolved
2014-03-27 06:19 MarvinPA Fixed in Branch => 0.14 development branch
2014-03-27 06:19 MarvinPA Resolution open => done
2014-03-27 06:19 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker