Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001955 [DCSS] Implementables minor have not tried 2010-07-12 20:32 2014-05-04 16:41
Reporter rob View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.8 ancient branch
Summary 0001955: unique altars in sprint 1
Description I think it'd improve sprint 1 play greatly without unbalancing it if the eleven available altars were always to eleven different gods. The god selection could stay as is (temple gods), though allowing beogh and jiyva could be considered.

Additional Information
12:27:36 <by> how hard would it be to make the altars in sprint 1 distinct?
12:31:02 <dpeg_> by: distinct?
12:31:14 <by> no triple sif muna among the 11 altars
12:31:22 <TGWi> doesn't C do that for you?
12:31:30 <by> TGWi: have you played sprint?
12:31:32 <dpeg_> by: yes, that sounds like a bug.
12:31:37 <TGWi> I have
12:31:41 <TGWi> sprint 1, and I know what you're talking about
12:31:53 <by> ok, because that map uses 'C'
12:32:02 <TGWi> isn't there a character that places altars sequentially? I guess it isn't C
12:32:25 <dpeg_> B, I think
12:33:06 <by> but that wouldn't be good here, either
12:33:49 <dpeg_> by: what distribution do you want?
12:34:37 <by> I'd say 11 random distinct altars; not sure about temple god restriction
12:35:30 <dpeg_> that could be done either with lua lists or with SHUFFLEs
12:37:01 <by> shuffles would require Note: 0000015 letters, right? don't think sprint 1 has that many le
ft over
12:42:14 <dpeg_> by: you can do it with NSUBSTs...
12:42:52 <dpeg_> NSUBST: _ = 1:A / *:_  ;  KFEAT: _ = altar of Zin  ; repeat
12:44:01 <TGWi> do you get more letters available if you make the parts with the altars into s
ubvaults?
12:44:19 <dpeg_> yes
12:44:41 <dpeg_> THat's another option, but it is a lot of work to SUBVAULTify a map after the
 fact.
12:44:52 -!- Twinge has quit [Ping timeout: 276 seconds]
12:45:05 <by> dpeg_: that would result in an even distribution of all listed gods?
12:45:16 <dpeg_> by: yes
12:47:54 <by> should it be A = altar of  Zin ?
12:48:05 <by> (trying to understand NSUBST)
12:49:00 <dpeg_> by: NSUBST: _ = 1:A / *:_ takes all _ symbols in the map and turns exactly on
e into an A (this assumes that A is not used elsewhere).
12:49:24 <dpeg_> All the rest stay _ symbols, so you can keep going with the two NSUBST / KFEA
T lines
12:49:51 <by> and what becomes of the As?
12:50:14 <dpeg_> just a moment
12:51:08 <dpeg_> KFEAT: A = altar_zin it seems to be
12:51:26 <by> but then this would guarantee a Zin altar
12:51:37 <dpeg_> ah, I see where you are coming from
12:51:45 <TGWi> put four or five dummy altars behind some permarock somewhere
12:51:52 <by> ugh
12:51:56 <TGWi> :\
12:52:05 <TGWi> I'd just make a subvault
12:52:15 <TGWi> s/just //
12:52:23 <dpeg_> by: then it's best to use _ on the map, and at the very end of the map (when 
letters are free again) do an NSUBST, which turns those many _ into one A, one B etc.
12:52:48 <by> ah, the letters can be reused? sounds good
12:52:52 <dpeg_> and then a SHUFFLE: ABCDE...Z (more letters than altars here) and the assign 
altars.
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0026041)
MarvinPA (developer)
2014-05-04 16:41

All sprints now reliably have altars to most gods (Ashenzari, Beogh being a couple of the occasional exceptions) every game.

- Issue History
Date Modified Username Field Change
2010-07-12 20:32 rob New Issue
2010-07-12 20:33 rob Additional Information Updated
2010-09-16 00:53 rob Category FR: Maps and Vaults => Implementables
2014-05-04 16:41 MarvinPA Note Added: 0026041
2014-05-04 16:41 MarvinPA Status new => resolved
2014-05-04 16:41 MarvinPA Fixed in Branch => 0.15 development branch
2014-05-04 16:41 MarvinPA Resolution open => done
2014-05-04 16:41 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker