Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011636 [DCSS] Bug Report minor have not tried 2018-08-25 22:30 2018-08-26 15:16
Reporter RoGGa View Status public  
Assigned To advil
Priority normal Resolution done  
Status resolved   Product Branch 0.22 old branch
Summary 0011636: when forgetting a Vehumet offered spell, it does not return to Spell Library
Description I used a scroll of amnesia to forget Lehudib's Crystal Spear so that I could memorize Shatter since Iron Shot is doing a good-enough job for now.

But Lehudib's Crystal Spear did not return in my Spell Library.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0032577)
advil (administrator)
2018-08-25 22:37

Just to check, have you found LCS in a book? If not, this is expected behavior, if so, it's a bug.
(0032578)
RoGGa (reporter)
2018-08-25 23:10

LCS was not in a book; it was offered by Vehumet as part of the set of the last 3 spells.

IMO, any of the last 3 spells should return to the top of Spell Library.

Had I known this was the intended behaviour, I would have bought the Book of Annihilations in a Bazaar.
(0032579)
RoGGa (reporter)
2018-08-25 23:56

Also, there is no way on the I screen (for memorized spells) to know which ones were offered by Vehumet AND that are not in any of the collected spell books.
(0032580)
advil (administrator)
2018-08-25 23:59

ah, possibly one could make this case for his final gift spells.

Re the second issue, probably in 0.23 I'll change it so that you can find out what book (or other source) a spell came from.
(0032583)
advil (administrator)
2018-08-26 15:16

I came up with a simpler solution: the new forget prompt will also tell you if the spell is not in your library ( https://github.com/crawl/crawl/commit/a8cb661cfcab [^] ). On reflection and a small bit of discussion, I think it's best if all vehumet gifts behave alike, so I don't think special-casing the final three is a good idea.

(Of course, an alternative simplification would be just have veh add gifts to your library, but I'll leave that for the moment.)

- Issue History
Date Modified Username Field Change
2018-08-25 22:30 RoGGa New Issue
2018-08-25 22:37 advil Note Added: 0032577
2018-08-25 23:10 RoGGa Note Added: 0032578
2018-08-25 23:56 RoGGa Note Added: 0032579
2018-08-25 23:59 advil Note Added: 0032580
2018-08-26 15:16 advil Note Added: 0032583
2018-08-26 15:16 advil Status new => resolved
2018-08-26 15:16 advil Fixed in Branch => 0.22 development branch
2018-08-26 15:16 advil Resolution open => done
2018-08-26 15:16 advil Assigned To => advil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker