Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011534 [DCSS] Bug Report crash always 2018-07-17 09:21 2018-07-23 04:33
Reporter kitchen_ace View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status closed   Product Branch 0.22 old branch
Summary 0011534: Crash when trying to use ` to enchant equipment with several scrolls
Description With more than one enchant weapon scroll, read the scroll and enchant a weapon, then press `. The game will crash, instead of enchanting that weapon again. Also happens with enchant armour scrolls, identification scrolls, probably others.
Additional Information
Tags ui-overhaul
Attached Files txt file icon crash-asdf-20180717-093710.txt [^] (51,852 bytes) 2018-07-17 15:46 [Show Content]
txt file icon crawl_2018-07-17-093714_Helix.crash.txt [^] (50,197 bytes) 2018-07-17 15:51 [Show Content]
? file icon menu.patch [^] (341 bytes) 2018-07-19 05:14 [Show Content]

- Relationships

-  Notes
(0032359)
kitchen_ace (reporter)
2018-07-17 09:50

I think the crash happens when using ` after any action that opens a new window actually.
(0032362)
advil (administrator)
2018-07-17 15:48
edited on: 2018-07-17 15:50

This is local tiles only (console seems ok). I've uploaded a crash dump and a full stack trace from the crash. As a first guess, it looks like the index on item_info isn't necessarily valid for some reason in this case.

(0032370)
collin38 (reporter)
2018-07-19 05:17

I've added a patch that fixes the issue. For some reason redo_prev_command didn't trigger a resize on item_info so the sizes didn't match up. This removes it for update_items, but there are a couple other places where prev_cmd_again short circuits the functions. Seems unnecessary.
(0032379)
aidanholm (developer)
2018-07-20 15:49

Thanks for reporting, and for the patch; fix pushed at 6887535748. I'm not entirely sure if the short-circuit checks were required for other obscure edge cases to work correctly, but fingers crossed...

- Issue History
Date Modified Username Field Change
2018-07-17 09:21 kitchen_ace New Issue
2018-07-17 09:50 kitchen_ace Note Added: 0032359
2018-07-17 15:46 advil File Added: crash-asdf-20180717-093710.txt
2018-07-17 15:46 advil File Added: crawl_2018-07-17-093714_Helix.crash
2018-07-17 15:48 advil Note Added: 0032362
2018-07-17 15:48 advil Status new => confirmed
2018-07-17 15:49 advil Tag Attached: ui-overhaul
2018-07-17 15:50 advil Note Edited: 0032362
2018-07-17 15:51 advil File Added: crawl_2018-07-17-093714_Helix.crash.txt
2018-07-17 15:51 advil File Deleted: crawl_2018-07-17-093714_Helix.crash
2018-07-19 05:14 collin38 File Added: menu.patch
2018-07-19 05:17 collin38 Note Added: 0032370
2018-07-19 05:18 collin38 Issue Monitored: collin38
2018-07-20 15:49 aidanholm Note Added: 0032379
2018-07-20 15:49 aidanholm Status confirmed => resolved
2018-07-20 15:49 aidanholm Fixed in Branch => 0.22 development branch
2018-07-20 15:49 aidanholm Resolution open => done
2018-07-20 15:49 aidanholm Assigned To => aidanholm
2018-07-23 04:32 kitchen_ace Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker