Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011533 [DCSS] Bug Report trivial always 2018-07-17 09:16 2018-07-24 12:08
Reporter kitchen_ace View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status closed   Product Branch 0.22 old branch
Summary 0011533: Long artefacts wrap text on small displays in the % screen
Description See attached screenshot.
Additional Information
Tags No tags attached.
Attached Files png file icon 2018-07-16_05:13:56.png [^] (156,112 bytes) 2018-07-17 09:16
? file icon wordwrap.cs [^] (51,621 bytes) 2018-07-23 04:23

- Relationships

-  Notes
(0032407)
aidanholm (developer)
2018-07-23 04:01

I can't reproduce this on local tiles, and there's code for shortening item names to fit the screen that's a few years old. Could you attach a crawl save file that exhibits the problem? Thanks
(0032408)
kitchen_ace (reporter)
2018-07-23 04:28
edited on: 2018-07-23 04:29

Attached a save with wizmode that uses the same item. I've seen it on other artefacts though.

I'm running crawl in windowed mode at 1014*480 resolution. Playing around with the settings a bit it looks like starting at a higher resolution and then resizing the window might cause the line to wrap/truncate properly?

(0032422)
aidanholm (developer)
2018-07-23 18:37

Ah, d'oh: I didn't check with a wider screen. Fixed now at 978c4e9634, by forcing it to always be 80 columns wide.

The character overview screen is one of the (many) UIs which is basically just a blob of text. I plan to eventually get around to converting it to the new UI system... one of these days...

- Issue History
Date Modified Username Field Change
2018-07-17 09:16 kitchen_ace New Issue
2018-07-17 09:16 kitchen_ace File Added: 2018-07-16_05:13:56.png
2018-07-23 04:01 aidanholm Note Added: 0032407
2018-07-23 04:23 kitchen_ace File Added: wordwrap.cs
2018-07-23 04:28 kitchen_ace Note Added: 0032408
2018-07-23 04:29 kitchen_ace Note Edited: 0032408
2018-07-23 18:37 aidanholm Note Added: 0032422
2018-07-23 18:37 aidanholm Status new => resolved
2018-07-23 18:37 aidanholm Fixed in Branch => 0.22 development branch
2018-07-23 18:37 aidanholm Resolution open => done
2018-07-23 18:37 aidanholm Assigned To => aidanholm
2018-07-24 12:08 kitchen_ace Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker