Need help with 0.9 build


Problems running or configuring the software, commands & options, compiling, different platforms, using the interface, documentation, etc.

Dungeon Dilettante

Posts: 1

Joined: Tuesday, 30th August 2011, 22:51

Post Tuesday, 30th August 2011, 23:00

Need help with 0.9 build

I've just registered this account. My thanks to developers for producing and continius development of such an amazing game. 0.9 is great improvement, I was having a blast with it.

However unfrotunately I have a problem with Crawl 0.9 install. Every time I approach Lair I get red error message:

Lua error: c:\Relax\Crawl\/dat/des/branches/lair.des:291: unknown monster: "megabat" x25

There is no mentioning of "megabat" in lair.des, just bats. Also I have the similar problem with (Lua error: .....: unknown mosnter "gila monster" ) As far as I understand, these are monsters that should no longer be in 0.9, right?

I am running stable 0.9 release, but before that I was running 0.8 on the same computer. OS is Wondows 7.

Now something very strange has been going on my comp with Crawl 0.8 and Crawl 0.9 installations. I've suspected that they got mixed up somehow (I originally installed 0.9 in the same directory as 0.8 was installed).

So to remedy this situation I've manually deleted all files and folders from the Crawl's installed directory. (c:\crawl) Then I've installed fresh Crawl 0.9 stable install at the same directory, now that I was sure that no files from previous builds have remained there. But I still got the same error. Every time I get to Lair. (tried 3 times already)

As far as I can tell, the only remaining parts of the earlier crawl installs on my computer are "morgue" and "saves" folders in the C:\Users\NNN\AppData\Roaming\crawl directory, that contained data from my previous attemts. I kept them so I would have old HOF and ghosts. But they shouldn't affect monsters in dungeons and cause this type of errors, should they?

BTW there is a similar bug (4437) in bug tracking system. After trying to find solution and failing, I've registered and updated that bug's info.

(https://crawl.develz.org/mantis/view.php?id=4437 )

Any help or advice would be greatly appreciated!

Thanks a lot!
User avatar

Dungeon Master

Posts: 4031

Joined: Thursday, 16th December 2010, 20:37

Location: France

Post Wednesday, 31st August 2011, 08:03

Re: Need help with 0.9 build

Try deleting the saves\des directory.
<+Grunt> You dereference an invalid pointer! Ouch! That really hurt! The game dies...

Return to Technical Support

Who is online

Users browsing this forum: No registered users and 3 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.