Save file compatibility 0.7 vs 0.9


Problems running or configuring the software, commands & options, compiling, different platforms, using the interface, documentation, etc.

Dungeon Dilettante

Posts: 2

Joined: Monday, 22nd August 2011, 23:12

Post Monday, 22nd August 2011, 23:17

Save file compatibility 0.7 vs 0.9

Hi
I've been enjoying Crawl v0.7.1, thanks to all the developers. I noticed the other day that 0.8 has been and gone, and 0.9 is out, so I decided to upgrade. I have two characters alive, but I can't see them in 0.9 although they are fine in 0.7. Please can anyone help me with my questions:

1) Can I upgrade my characters from v0.7 to v0.9?
2) If not, can I start some v0.9 characters and also continue to play my v0.7 characters without either one corrupting the other?

Many thanks,
Adam
User avatar

Dungeon Master

Posts: 4031

Joined: Thursday, 16th December 2010, 20:37

Location: France

Post Tuesday, 23rd August 2011, 07:12

Re: Save file compatibility 0.7 vs 0.9

1) No. 0.9 is save compatible with 0.8, but not with 0.7
2) Yes, but you'll have to keep 2 separate crawl installations.
<+Grunt> You dereference an invalid pointer! Ouch! That really hurt! The game dies...

For this message the author galehar has received thanks:
AdamS

Dungeon Dilettante

Posts: 2

Joined: Monday, 22nd August 2011, 23:12

Post Tuesday, 23rd August 2011, 14:05

Re: Save file compatibility 0.7 vs 0.9

Thanks galehar, it works fine. V0.9 seems good from a quick look.

Abyss Ambulator

Posts: 1196

Joined: Friday, 17th December 2010, 13:59

Location: Maryland, USA

Post Wednesday, 24th August 2011, 13:11

Re: Save file compatibility 0.7 vs 0.9

Would importing the 0.7.1 characters into 0.8 and saving them there, then importing them once again into 0.9 work?
You fall off the wall. You have a feeling of ineptitude.
User avatar

Dungeon Master

Posts: 4031

Joined: Thursday, 16th December 2010, 20:37

Location: France

Post Wednesday, 24th August 2011, 13:19

Re: Save file compatibility 0.7 vs 0.9

Stormfox wrote:Would importing the 0.7.1 characters into 0.8 and saving them there, then importing them once again into 0.9 work?

No. 0.7 and 0.8 are not compatible. We had to break save compat when we reduced Elf to 5 levels.
<+Grunt> You dereference an invalid pointer! Ouch! That really hurt! The game dies...

Abyss Ambulator

Posts: 1196

Joined: Friday, 17th December 2010, 13:59

Location: Maryland, USA

Post Wednesday, 24th August 2011, 13:25

Re: Save file compatibility 0.7 vs 0.9

Ah well. That's what I get for playing online only and having all of that stuff managed for me. ;)
You fall off the wall. You have a feeling of ineptitude.

Return to Technical Support

Who is online

Users browsing this forum: No registered users and 6 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.