Disabling rogue-like movement keys


Problems running or configuring the software, commands & options, compiling, different platforms, using the interface, documentation, etc.

Dungeon Dilettante

Posts: 2

Joined: Tuesday, 29th November 2011, 23:38

Post Tuesday, 29th November 2011, 23:52

Disabling rogue-like movement keys

hi

i'm trying to get rid of the rogue-like movement keys in crawl (hjklyubn).
i was asking in ##crawl and the suggestion was to macro it to the space bar (or any key that does nothing i guess), but when i do that it also kills
movement on the corresponding numpad key (turned off, ofc).
so if i assign a macro to 'h' and hit <space bar> when it asks for the key, 'h' stops moving me to the left, as does numpad 4.
this is playing trunk 0.10 downloaded a couple of days ago (but was already the case back since), console, and on a qwertz keyboard.

i'd just really want to get rid of the rogue-like movement keys.
User avatar

Crypt Cleanser

Posts: 644

Joined: Wednesday, 14th September 2011, 09:36

Location: <---

Post Wednesday, 30th November 2011, 04:50

Re: Disabling rogue-like movement keys

First they are called Vi key, because it comes from Vi (and Ed...) even before rogue exist.

Second there it is a file called no_vi_command_keys in the setting folder : https://gitorious.org/crawl/crawl/blobs/master/crawl-ref/settings/no_vi_command_keys.txt.

Just follow the instructions.

Dungeon Dilettante

Posts: 2

Joined: Tuesday, 29th November 2011, 23:38

Post Wednesday, 30th November 2011, 18:34

Re: Disabling rogue-like movement keys

thanks for the clarification, that made searching the docs for the relevant entries easier.

first i've pasted all the bindkey entries from no_vi_commands_keys.txt to my init.txt.
numpad movement doesn't work anymore.

then i found the entry in the init.txt under 6-d (# Override the vi movement keys with a non-command.) and uncommented the "include = no_vi_command_keys.txt line"
and deleted the entries i've made in the first step.
numpad movement doesn't work anymore.

Lair Larrikin

Posts: 17

Joined: Saturday, 5th November 2011, 08:47

Post Friday, 2nd December 2011, 07:29

Re: Disabling rogue-like movement keys

I just tried it in trunk and it seems to only disable the letter keys, is numlock on? Alternatively could you disable both vi and numpad then remacro the numpad keys to the movement directions?

Return to Technical Support

Who is online

Users browsing this forum: No registered users and 0 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.