WEBTILES - nearly unplayable


Problems running or configuring the software, commands & options, compiling, different platforms, using the interface, documentation, etc.

User avatar

Halls Hopper

Posts: 57

Joined: Sunday, 25th March 2012, 21:55

Post Thursday, 31st May 2012, 18:22

WEBTILES - nearly unplayable

Hello!

Webtiles are nearly unplayable because of the lags,
which are giantic, sometimes up to 5-seconds ones.
This makes a game nearly impossible to play.
Also, the web connection sometimes failes (connection is lost).

I use the newest Ubuntu with Mozilla Firefox browser.
What could be a reason? CPU, OS, server, internet browser?

Thanx
User avatar

Pandemonium Purger

Posts: 1319

Joined: Monday, 24th October 2011, 06:13

Post Thursday, 31st May 2012, 18:47

Re: WEBTILES - nearly unplayable

Webtiles is a luxury in the stage of infancy. Occasionally, like some luxury web services, the performance does not meet expectations. You've left many details out:

when you are experiencing this delay, is it exclusive to webtiles? Did you encounter any other slowdowns on any other services? Did you bother to check? Do you often experience slowdowns with your connection? Is your computer able to handle Webtiles? How long have you been playing webtiles - are you gauging this against the normal experience you've come to expect?

Every complaint that I've read about webtiles on this forum plays out like a "is this website down for n e 1 else??????" post. Five minutes later that person checks the website, and its back, making the thread unnecessary and the poster look foolish for rushing to judgement.
seattle washington. friends for life. mods hate on me and devs ignore my posts. creater of exoelfs and dc:pt
User avatar

Halls Hopper

Posts: 57

Joined: Sunday, 25th March 2012, 21:55

Post Thursday, 31st May 2012, 19:23

Re: WEBTILES - nearly unplayable

As far as I know, I have a good, fast internet connection.
I never had any problems with any other websites.
I`m playing Webtiles about a month (maybe more),
rather a lot (sometimes few hours daily).
The problems repeats periodically:
sometimes I can play without any big lags
(no slowdowns), sometimes I barely can play,
sometimes it`s even so bad that it disconnects me.

I have Acer Aspire 5100 laptop with 2 Ghz CPU,
1.5 Gb RAM and ATI Radeon Xpress 1100 card.
I use newest Ubuntu with standard Firefox.
I live in Poland (the Webtile`s server is in Germany?).
I could only guess it`s something with the main server
(I thought it might be overloaded if there`s a lot
of people on the server, but it seems I was wrong,
because sometimes I get lags when there`s not a big crowd).
I thought it`s something with my CPU,
but it`s ok with other games (also online games).
I`m not sure what`s wrong - is it something
with my machine or internet connection or something with the server?

Vestibule Violator

Posts: 1567

Joined: Friday, 21st January 2011, 22:56

Post Thursday, 31st May 2012, 20:38

Re: WEBTILES - nearly unplayable

The server is generally overloaded. I don't know if that's the cause of your problems. Some browsers (or Windows? I don't remember) also seem to force something like a 200ms lag on you, but that's an entirely different issue.
User avatar

Swamp Slogger

Posts: 155

Joined: Tuesday, 22nd February 2011, 18:24

Post Thursday, 14th June 2012, 07:33

Re: WEBTILES - nearly unplayable

It runs pretty poorly on Firefox for me (no idea why, it runs fine for friends on firefox) , I use Chrome or Opera to play webtiles and get 0 lag most of the time.

Lair Larrikin

Posts: 17

Joined: Tuesday, 12th June 2012, 05:56

Post Thursday, 14th June 2012, 21:12

Re: WEBTILES - nearly unplayable

I have played Webtiles every day for the past month and a half. In the past two or three weeks, I have experienced some periods of extreme lag, but this is generally around the same time almost daily. When I first started playing, this didn't happen, but I also play a lot more than I did when I didn't have so much down time. I assume that the time that people play a lot, it gets quite taxing on the servers(?). Though the lag can be a few seconds at a time and repeated 7-8 times within 5-10 minutes, it's never enough to make me use the local version. I think it's German-based, anyway, so that could also be a problem. Not really sure if I even know what I'm talking about, but I do experience similar problems. They just don't make the game "unplayable".

I use Google Chrome, though. I haven't played on any other web browser, but other than that occasional lag and disconnect, it's never really hindered my playing experience. Maybe try a different browser or play at a different time and see if that fixes the problem.

Snake Sneak

Posts: 103

Joined: Thursday, 21st July 2011, 15:27

Post Monday, 23rd July 2012, 16:27

Re: WEBTILES - nearly unplayable

Using chrome and windows 7 from east coast US. I've always played on CDO. I'm having a an usual amount of lag. More importantly the screen is not redrawing after each turn or after I bring up a menu (like inventory) until I take another turn, meaning if I step on an item the message will show up pretty quickly, "You see here a ..." though my character won't move to the square until I move again making the display always behind by a turn. If I switch tabs on chrome then the display is correct again. It also seems like the new messages may be appearing below the bottom of the screen sometimes though. Any thoughts?

Edit: Spectating seems smoother though still a bit jerky, but it's hard for me to tell what the input is of course. Over at http://crawlus.somatika.net:8080/#play-dcss-web-trunk I have the same problems, but it seems a little less severe. It also seems like it was drawing better when there were less monsters around, but that may be because it just becomes much more obvious then. Actually, it's unplayable there too. At first when I logged in it seemed responsive, but not for long.

Ziggurat Zagger

Posts: 3163

Joined: Friday, 6th January 2012, 18:45

Post Monday, 23rd July 2012, 16:58

Re: WEBTILES - nearly unplayable

I'm not experiencing any of this using FireFox 14 on WinXP. CDO is usually a little laggy for me, but I always attribute that to the fact that it's in Germany and has a lot of people on. Somatika runs great for me.

Snake Sneak

Posts: 103

Joined: Thursday, 21st July 2011, 15:27

Post Monday, 23rd July 2012, 17:17

Re: WEBTILES - nearly unplayable

Thanks, firefox seems to run it properly. Not sure what the issue with chrome is.

Dungeon Master

Posts: 125

Joined: Sunday, 8th May 2011, 21:54

Post Monday, 23rd July 2012, 19:14

Re: WEBTILES - nearly unplayable

Guppyfry wrote:Thanks, firefox seems to run it properly. Not sure what the issue with chrome is.
Could you check what about:gpu says about Canvas acceleration, and try activating "Disable accelerated 2d canvas" and "Disable deferred 2d canvas" in about:flags?

Snake Sneak

Posts: 103

Joined: Thursday, 21st July 2011, 15:27

Post Thursday, 26th July 2012, 16:42

Re: WEBTILES - nearly unplayable

Firefox still runs great. Chrome is still acting up -

I don't have any flags for "2d canvas" anything

From my "about:gpu" in chrome:

Graphics Feature Status
Canvas: Hardware accelerated
Compositing: Hardware accelerated
3D CSS: Hardware accelerated
CSS Animation: Software animated.
WebGL: Hardware accelerated
WebGL multisampling: Hardware accelerated
Problems Detected
Accelerated CSS animation has been disabled at the command line.

Return to Technical Support

Who is online

Users browsing this forum: No registered users and 3 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.