Page 1 of 1

Unable to edit colors in 0.20.1 console (Win32)

PostPosted: Thursday, 16th November 2017, 11:48
by Roderic
Sup folks! I have made a leap to 0.20.1 from 0.16 trunk and I have noticed a lot of changes! (time will tell how I feel with them).

I used to tweak some console glyphs in my local installation and to my surprise I am unable to change the color assignation, only the character. I have tried to enable some old configurations in the init.txt and only I notice the change in the letter but the color remains the same (both in the descriptions menu and in the game). This affects to the "monster_glyph +=" and to the "feature", the ones I tried. I have been always inheriting the editions from init.txt to init.txt but now I cannot get what I want. It's not like I can't get used to the default but I like to know that everything works as expected.

My local is stable 0.20.1 Win7 32-bit. Last time tried an edition was with 0.15 stable build. At some point it changed, it seems.

Re: Unable to edit colors in 0.20.1 console (Win32)

PostPosted: Saturday, 18th November 2017, 16:35
by neil
It should be working the same as before:

mon_glyph += goblin : magenta G

Are you specifically changing the colour to darkgrey? If so, because of some changes to make things work better with eight-color terminals, it will by default show up as blue instead. To fix that, also use the setting:

bold_brightens_foreground = true

Maybe that should be set to true by default on Windows, since there's just the one console there.

Re: Unable to edit colors in 0.20.1 console (Win32)

PostPosted: Monday, 20th November 2017, 23:01
by Roderic
I got something, thanks.

By default I didn't get the blue replacing dark grey but I have set up the bold_brightens_foreground = true in the init for the local. The changes weren't related to dark grey, however.

The trivial example of the goblin you have posted has taken effect on the screen/viewport but somehow this is not reflected in the game information list, which only shows the symbol change but not the new assigned colour. I remember that this was working in 0.15 and older versions (the fastest way to check all changes).

Previously to the bold_brightens_foreground=true I didn't see the new settings either in the viewport or in the information list. It's something I guess. Probably there's something missing related to the information list, which seems detached from the viewport in terms of color management.