Page 1 of 1

Ctrl-O doesn't work when connecting by telnet.

PostPosted: Monday, 15th August 2011, 19:31
by Jeremiah
I have just discovered on my latest online character that I can't get ctrl-o for dungeon overview to work when connecting by telnet.

I have found the same happens on both CAO and CDO, in 0.8, 0.9 and 0.10 trunk. I would normally be connecting by ssh to CAO, but I started this game on CDO and I can't make head nor tail of the method for getting the ssh-key and using it to connect, so I'm stuck with telnet.

Anyone know of any workarounds for this?

Re: Ctrl-O doesn't work when connecting by telnet.

PostPosted: Tuesday, 16th August 2011, 03:12
by jejorda2
viewtopic.php?f=9&t=2305&view=unread#unread

Pressing *o works for me. (asterisk, then o, rather than the two keys together.)

Re: Ctrl-O doesn't work when connecting by telnet.

PostPosted: Tuesday, 16th August 2011, 10:12
by Jeremiah
Thanks, that works. That's something I didn't know about, using * to emulate ctrl...

Re: Ctrl-O doesn't work when connecting by telnet.

PostPosted: Tuesday, 16th August 2011, 11:15
by dassem
Saying whether you're running Win, Lin, or Mac might help with getting help.
Personally it's been a long time since I did it, so I forgot all the details. :?

My suggestions are: Use putty. Don't forget to set your keymap to Nethack. Follow the instructions to get the key (they are detailed, so it's a lot easier than it looks).
Doing so makes logging on a bit faster and more painless too.

And that's a useful work-around!

Re: Ctrl-O doesn't work when connecting by telnet.

PostPosted: Tuesday, 16th August 2011, 11:36
by Jeremiah
Ok, I'm using Mac OS X 10.4.11

I tried following the instructions to get the key, but a bit of research reveals that I don't have wget installed and would have to build it myself. I'm not a programmer, and have no idea about building or compiling.

Anyway, using * works, so that will do as a workaround for now, at least until 0.9 becomes available on webtiles.

Re: Ctrl-O doesn't work when connecting by telnet.

PostPosted: Tuesday, 16th August 2011, 15:20
by jejorda2
Jeremiah wrote:Ok, I'm using Mac OS X 10.4.11

I tried following the instructions to get the key, but a bit of research reveals that I don't have wget installed

I think curl was installed by default on 10.4,so this would work instead of the wget command:
  Code:
curl -O http://crawl.akrasiac.org/cao_key

Or to skip the command line for downloading the file, just click this link in your browser and choose save as:
http://crawl.akrasiac.org/cao_key
I like to keep the key file in ~/.ssh/ but it will probably work anywhere.
If you use this commnd once:
  Code:
ssh-add cao_key

Then you can use a simpler command to ssh into the server:
  Code:
ssh crawl@crawl.develz.org

I think I remember Apple not using standard ssh libraries at some point, but I think that was 10.2 not 10.4, but my memory could be wonky and I haven't researched it.