DC performance issues


Problems running or configuring the software, commands & options, compiling, different platforms, using the interface, documentation, etc.

Temple Termagant

Posts: 5

Joined: Friday, 7th January 2011, 01:35

Post Friday, 7th January 2011, 01:42

DC performance issues

Hi, I'm just DLed dungeon crawl and it runs really laggy. I don't see it taking up much comp. resources so, I was wondering if anyone had any ideas on what to do about this? also if someone could tell me how to get it to show the amount of turns in-game, I'd appreciate it.

Vaults Vanquisher

Posts: 447

Joined: Thursday, 16th December 2010, 22:10

Post Friday, 7th January 2011, 03:30

Re: DC performance issues

the option for showing turns is show_gold_turns (set it to true; it also shows gold)

For this message the author MrMisterMonkey has received thanks:
Phlarb

Temple Termagant

Posts: 5

Joined: Friday, 7th January 2011, 01:35

Post Friday, 7th January 2011, 03:40

Re: DC performance issues

I'm running tiles.

A friend showed me the the game and console looks way different from what i saw. and thats why im asking about the turns being shown because they arnt..

I told myself i wouldnt get it after dieing so many times, lol( I like the VpNe ). but its so addicting!

right, thanks MrMrMonkey... where and how do i put that in? > :D newbie here< But my primary concern is the lag...
Image

Vaults Vanquisher

Posts: 447

Joined: Thursday, 16th December 2010, 22:10

Post Friday, 7th January 2011, 03:52

Re: DC performance issues

you want to put the "show_gold_turns = true" somewhere in your rcfile; by default that should be ~/.crawlrc on unix-likes and init.txt (though I don't know where) on windows

As for the lag, if that's 0.8, it might be the same issue as https://crawl.develz.org/mantis/view.php?id=3160 (though I play console online so I don't really know much about tiles/lag)

For this message the author MrMisterMonkey has received thanks:
Phlarb

Temple Termagant

Posts: 5

Joined: Friday, 7th January 2011, 01:35

Post Friday, 7th January 2011, 03:59

Re: DC performance issues

um thanks monkey for that. I understood almost none of it. lol. but thanks. as far as i can tell its 0.7.1. any and all input or tidbits would still be appreciated.
User avatar

Vestibule Violator

Posts: 1533

Joined: Thursday, 16th December 2010, 20:52

Post Friday, 7th January 2011, 07:49

Re: DC performance issues

Some crappy video cards don't work well with the graphics library that DCSS has used since 0.5. Download version 0.4.5 and see if that runs faster.

While you're running that version, try a heavy-armoured berserker and find an amulet of resist slowing!

For this message the author danr has received thanks:
Phlarb
User avatar

Dungeon Master

Posts: 4031

Joined: Thursday, 16th December 2010, 20:37

Location: France

Post Friday, 7th January 2011, 10:59

Re: DC performance issues

Dungeon Crawl uses OpenGL for rendering tiles. Very slow game usually means software rendering. Try installing decent graphic drivers.
<+Grunt> You dereference an invalid pointer! Ouch! That really hurt! The game dies...

For this message the author galehar has received thanks:
Phlarb

Temple Termagant

Posts: 5

Joined: Friday, 7th January 2011, 01:35

Post Friday, 7th January 2011, 22:40

Re: DC performance issues

Thanks everyone, its now running perfect. now if someone could dumb down what monkey said?

MrMisterMonkey wrote:you want to put the "show_gold_turns = true" somewhere in your rcfile; by default that should be ~/.crawlrc on unix-likes and init.txt (though I don't know where) on windows
User avatar

Vestibule Violator

Posts: 1533

Joined: Thursday, 16th December 2010, 20:52

Post Friday, 7th January 2011, 23:29

Re: DC performance issues

Phlarb wrote:Thanks everyone, its now running perfect. now if someone could dumb down what monkey said?

MrMisterMonkey wrote:you want to put the "show_gold_turns = true" somewhere in your rcfile; by default that should be ~/.crawlrc on unix-likes and init.txt (though I don't know where) on windows

Somewhere in the folder where you installed Crawl, there should be a file called init.txt. Open that file in Notepad and make sure it contains the text "show_gold_turns = true"
User avatar

Snake Sneak

Posts: 105

Joined: Sunday, 19th December 2010, 19:28

Location: UK

Post Saturday, 8th January 2011, 16:56

Re: DC performance issues

I've just started using todays 0.8 windows tiles build instead of a build dated from just after Christmas, the performance seems to have taken a big hit, auto explore runs at about half the speed now and levels with lava/steam almost make it grind to a halt, anyone else notice this?

I run on an intel dual core 2ghz pc with 4 gb ram and nvidia ion graphics (the graphics card isn't great, but it was previously good enough!).
User avatar

Snake Sneak

Posts: 105

Joined: Sunday, 19th December 2010, 19:28

Location: UK

Post Saturday, 8th January 2011, 17:13

Re: DC performance issues

Hmm, seems to be caused the new command tab/button icons. The version without it runs fine.
User avatar

Dungeon Master

Posts: 4031

Joined: Thursday, 16th December 2010, 20:37

Location: France

Post Saturday, 8th January 2011, 21:39

Re: DC performance issues

Can you give the exact version number of the build that gives you slowdown? I made a lot of changes to the detached tabs yesterday (0.8.0-a0-4390-gc2f102f), and I quickly tested and explored 4 levels, with all the default tabs and didn't experience any slowdown.
In the latest build, I added a tile_layout_priority option. By editing it, you can disable any or all detached tabs. If you keep experiencing slow down, please try to find out which one of the tab is causing it.
<+Grunt> You dereference an invalid pointer! Ouch! That really hurt! The game dies...

Spider Stomper

Posts: 197

Joined: Sunday, 2nd January 2011, 11:13

Post Saturday, 8th January 2011, 22:39

Re: DC performance issues

galehar wrote:Can you give the exact version number of the build that gives you slowdown? I made a lot of changes to the detached tabs yesterday (0.8.0-a0-4390-gc2f102f), and I quickly tested and explored 4 levels, with all the default tabs and didn't experience any slowdown.
In the latest build, I added a tile_layout_priority option. By editing it, you can disable any or all detached tabs. If you keep experiencing slow down, please try to find out which one of the tab is causing it.


Hm, I downloaded this version and the game still starts lagging after a while. I went into the tiles.txt and removed from th tile_layout_priority monster, spell and gold_turns or whatever is their exact name, yet when I start the game these tabs still appear there. Am I just not getting something here?
User avatar

Snake Sneak

Posts: 105

Joined: Sunday, 19th December 2010, 19:28

Location: UK

Post Saturday, 8th January 2011, 23:57

Re: DC performance issues

Jenx, you must remove the # from the beginning of the line.

I experience slow-down on 0.8.0-a0-4390-gc2f102f, but removing "command" from the tile_layout_priority option seems to have fixed it. Need to test more as I died shortly after reloading my save!

For this message the author Regnix has received thanks:
Jenx

Mines Malingerer

Posts: 32

Joined: Wednesday, 5th January 2011, 18:52

Post Sunday, 9th January 2011, 02:19

Re: DC performance issues

I had bad slowdown too, using tiles-0.8.0-a0-4377-g2e00b12. However, now that I switched to tiles-0.8.0-a0-4390-gc2f102f, it's gone. Even with the new command console present.

I have similar stats to Regnix, except I have a GeForce 9400, and Windows 7.
User avatar

Snake Sneak

Posts: 105

Joined: Sunday, 19th December 2010, 19:28

Location: UK

Post Sunday, 9th January 2011, 12:08

Re: DC performance issues

I've done more testing today, and I can confirm that, removing "command" from tile_layout_priority on version 0.8.0-a0-4390-gc2f102f (windows 7, tiles) has fixed my performance issues.

Spider Stomper

Posts: 197

Joined: Sunday, 2nd January 2011, 11:13

Post Sunday, 9th January 2011, 12:10

Re: DC performance issues

Regnix wrote:I've done more testing today, and I can confirm that, removing "command" from tile_layout_priority on version 0.8.0-a0-4390-gc2f102f (windows 7, tiles) has fixed my performance issues.


Seconding this. Once you remove command the game runs smoothly even on levels with water and lots of enemies moving around.
User avatar

Dungeon Master

Posts: 4031

Joined: Thursday, 16th December 2010, 20:37

Location: France

Post Sunday, 9th January 2011, 12:58

Re: DC performance issues

OK, thanks all for your feedback. I've disabled detaching the command tab by default until we fix it.
<+Grunt> You dereference an invalid pointer! Ouch! That really hurt! The game dies...

Return to Technical Support

Who is online

Users browsing this forum: No registered users and 3 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.