Compiling Crawl on Ubuntu 16.04

Questions, Explanations, Howtos

Tartarus Sorceror

Posts: 1739

Joined: Tuesday, 13th March 2012, 02:48

Post Thursday, 6th July 2017, 01:43

Compiling Crawl on Ubuntu 16.04

I had this Ubuntu VM sitting around so I decided to compile crawl on it. Was pretty straightforward, mostly from INSTALL.txt.

First I did this on command line:
sudo apt install git
git clone
cd crawl
git submodule update --init
cd crawl-ref/source/

After ten minutes of compiling, I got this error: fatal error: term.h: No such file or directory

So I googled that error and tried this:
sudo apt install libncurses5-dev

After another ten minutes of compiling, I got more errors starting out like: error: ‘get_wch’ was not declared in this scope

Did some more googling and tried:
sudo apt install libncursesw5-dev

Fifteen minutes later, compiling finished! I started crawl with:

For this message the author Rast has received thanks:
User avatar

Zot Zealot

Posts: 982

Joined: Monday, 29th September 2014, 09:04

Post Thursday, 6th July 2017, 02:04

Re: Compiling Crawl on Ubuntu 16.04

The INSTALL.txt layout is confusing, but the packages needed are actually documented in the "Building on Unix (Linux, *BSD, Solaris, etc.)" section:
Prerequisites (Debian):

On Debian-based systems (Ubuntu, Mint, ...), you can get all dependencies by
typing the following as root/sudo:
apt-get install build-essential libncursesw5-dev bison flex liblua5.1-0-dev \
libsqlite3-dev libz-dev pkg-config libsdl2-image-dev libsdl2-mixer-dev \
libsdl2-dev libfreetype6-dev libpng-dev ttf-dejavu-core
(the last five are needed only for tiles builds). This is the complete set,
with it you don't have a need for the bundled "contribs".

For this message the author chequers has received thanks:

Return to Coding

Who is online

Users browsing this forum: No registered users and 2 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.