travis build failing on fresh fork


Questions, Explanations, Howtos

Halls Hopper

Posts: 74

Joined: Sunday, 21st February 2016, 14:55

Post Thursday, 25th January 2018, 18:58

travis build failing on fresh fork

I made a new fork of crawl, and intend it to very closely follow the main crawl code, with only variations activated by init script options. But I'm having trouble getting the travis build working. I get this error message:

  Code:
Failed to run 'sudo apt-get install gdb liblua5.1-0-dev liblua5.1-0-dbg'


Has anyone run into this with travis?

Tomb Titivator

Posts: 772

Joined: Monday, 29th September 2014, 09:04

Post Thursday, 25th January 2018, 21:04

Re: travis build failing on fresh fork

Can you link to the full build log?

Halls Hopper

Posts: 74

Joined: Sunday, 21st February 2016, 14:55

Post Thursday, 25th January 2018, 21:58

Re: travis build failing on fresh fork

Here's the link to the travis build:

https://travis-ci.org/jeremygurr/dcss_s ... /333428259

Tomb Titivator

Posts: 772

Joined: Monday, 29th September 2014, 09:04

Post Thursday, 25th January 2018, 23:22

Re: travis build failing on fresh fork

That build log shows a pull request failing to download. Which seems weird but unrelated.

Dungeon Master

Posts: 283

Joined: Monday, 18th August 2014, 20:04

Post Friday, 26th January 2018, 01:01

Re: travis build failing on fresh fork

It's fairly unclear to me why the crawl builds aren't having this problem (we might be grandfathered in to an old default), but it looks like your builds are always running on the container-based version of trusty on EC2, which doesn't support sudo. Our builds run on GCE, which does. Relevant log here, as chequers pointed out the one linked above has something else going on. You can see the most important error message on the call to apt.pl if you expand that section of the build, apparently it doesn't error right then (it probably should). If you put in your .travis.yml:

  Code:
sudo: required


This should force using the non-container-based GCE build environment.

Dungeon Master

Posts: 283

Joined: Monday, 18th August 2014, 20:04

Post Friday, 26th January 2018, 01:17

Re: travis build failing on fresh fork

Found it: "any Linux projects activated after February 14th [2015] that do not contain explicit sudo (or ping) usage will be routed to the container-based infrastructure."

I'll probably just modify the dcss .travis.yml file to be explicit so you can wait on that and pull from upstream if you want..edit: I have pushed that change to crawl's .travis.yml, but it's the same file as the irc bot stuff so you probably don't want to pull from upstream.

Halls Hopper

Posts: 74

Joined: Sunday, 21st February 2016, 14:55

Post Friday, 26th January 2018, 07:03

Re: travis build failing on fresh fork

Sweet, it's working now, thanks for the quick responses and fixes. It merged with my changes just fine, no conflicts.

Now I just have to figure out how to get github to not default my pull requests to be against the upstream master instead of defaulting to merging the pull request into my own repo.

Return to Coding

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.