Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009954 [DCSS] Bug Report major always 2015-09-14 09:01 2016-11-12 00:00
Reporter Ironfoot View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.17 ancient branch
Summary 0009954: Eyeball/slime shape-shifters cause moral dilemma
Description When worshipping Jiyva,

Shapeshifters shifted into an eyaball or slime type of monster are hostile and will attack you, but attacking them back would put you under penance.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0009590resolvedwheals Slime shaped shapeshifters warn of jiyva pennance 
has duplicate 0008597closedwheals Hostile Pulsating Lamp cannot be attacked with Jiyva 
has duplicate 0010564closedPleasingFungus Shapeshifter in friendly form neither appears friendly, nor can be attacked 

-  Notes
(0029497)
crate (reporter)
2015-09-14 09:03

The game actually only claims attacking them gives you penance, when in practice it does not. Still a bug, obviously (it shouldn't claim penance, and the Jiyva player knows they're shapeshifters because they're not friendly).
(0031224)
PleasingFungus (administrator)
2016-11-11 23:59

Fixed in 2417096, thanks!

- Issue History
Date Modified Username Field Change
2015-09-14 09:01 Ironfoot New Issue
2015-09-14 09:03 crate Note Added: 0029497
2015-09-16 02:25 wheals Relationship added has duplicate 0009590
2015-09-16 02:25 wheals Relationship added has duplicate 0008597
2016-07-14 17:42 PleasingFungus Relationship added has duplicate 0010564
2016-11-11 23:59 PleasingFungus Note Added: 0031224
2016-11-11 23:59 PleasingFungus Status new => resolved
2016-11-11 23:59 PleasingFungus Fixed in Branch => 0.20 development branch
2016-11-11 23:59 PleasingFungus Resolution open => done
2016-11-11 23:59 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker