Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009914 [DCSS] Patches tweak always 2015-08-17 23:19 2015-08-21 06:46
Reporter Bodrick View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.17 ancient branch
Summary 0009914: No prompt before quaffing !mut while wearing rMut or worshipping Zin
Description If you worship Zin and quaff a known potion of mutation (beneficial or otherwise), there's no confirmation prompt. This can be annoying if you accidentally hit the wrong key while quaffing.
Additionally, if you are wearing rMut and are trying to quaff a known potion of mutation, this patch will also warn you of that.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Ask-when-quaffing-mut-while-wearing-rMut-or-worshipp.patch [^] (2,019 bytes) 2015-08-17 23:19 [Show Content]

- Relationships

-  Notes
(0029418)
neil (administrator)
2015-08-21 06:46

Applied in trunk (0.17-a0-1703-g5ae10a0), thanks!

It would be nice to apply this to mutagenic chunks as well, but that seemed to be a little trickier because of auto_eat_chunks and easy_eat_chunks.

- Issue History
Date Modified Username Field Change
2015-08-17 23:19 Bodrick New Issue
2015-08-17 23:19 Bodrick File Added: 0001-Ask-when-quaffing-mut-while-wearing-rMut-or-worshipp.patch
2015-08-21 06:46 neil Note Added: 0029418
2015-08-21 06:46 neil Status new => resolved
2015-08-21 06:46 neil Fixed in Branch => 0.17 development branch
2015-08-21 06:46 neil Resolution open => done
2015-08-21 06:46 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker