Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009826 [DCSS] Bug Report major have not tried 2015-06-30 15:43 2015-07-02 09:04
Reporter Ololoev View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.17 ancient branch
Summary 0009826: Monster doesn't attack me!
Description Toadstool blocks way between me and emperor scorpion. I think my enemy should try to destroy any obstacle, but it just stand and loose turns!
I happened on CLAN webtiles.

MAP:
#    #.{^     {..#
##  ##.^#      ?.##
.## #{..#      ..?#
..# #??.#{     #.?#
..#  #.§#      #..#
..## #§.# {    #.?#
#..# #§{#     ##.?#
...###..#    {#P.##
.^.##..{##    #f@#
...##..(?#   ##P##
...###..?#{  #?s#
..## #..?## {#..#
###  #?.??####..#
.## ###..??.....#
..# #PP........##
..###P.?.......#
[..#.PP#..?..###


LOG:
Aim: an emperor scorpion (severely wounded)
You could not reach far enough!
Attack whom?
Press: ? - help, Dir - move target cursor, f/p - emperor scorpion
Aim: an emperor scorpion (severely wounded)
You could not reach far enough!
Attack whom?
Press: ? - help, Dir - move target cursor, f/p - emperor scorpion
Aim: an emperor scorpion (severely wounded)
You could not reach far enough!
Attack whom?
Press: ? - help, Dir - move target cursor, f/p - emperor scorpion
Aim: an emperor scorpion (severely wounded)
You reach to attack!
You hit the emperor scorpion but do no damage.
The emperor scorpion is severely wounded.
Attack whom?
Press: ? - help, Dir - move target cursor, f/p - emperor scorpion
Aim: an emperor scorpion (severely wounded)
You reach to attack! You hit the emperor scorpion.
You burn the emperor scorpion.
The emperor scorpion is almost dead.
Attack whom?
Press: ? - help, Dir - move target cursor, f/p - emperor scorpion
Aim: an emperor scorpion (almost dead)
You could not reach far enough!
Attack whom?
Press: ? - help, Dir - move target cursor, f/p - emperor scorpion
Aim: an emperor scorpion (almost dead)
You reach to attack! You hit the emperor scorpion.
You burn the emperor scorpion.
The emperor scorpion is almost dead.
Attack whom?
Press: ? - help, Dir - move target cursor, f/p - emperor scorpion
Aim: an emperor scorpion (almost dead)
You reach to attack! You barely miss the emperor scorpion.
The emperor scorpion is almost dead.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0029262)
neil (administrator)
2015-06-30 16:26
edited on: 2015-06-30 16:27

It seems to be very sensitive to exact positioning. In this case (based on the poster's) the enemry won't attack the toadstool, but if the player steps to the left it will:
#.@#
#P##
#s#

What seems to be happening is: _monster_move's main 3x3 loop fails to find a good direction, then _find_good_alternative_move fails as well. So as the last-chance fallback, it tries to move directly towards its target (the player), cutting down firewood in that direction. But that direct path is heading right into a wall.

Last-chance fallback: https://github.com/crawl/crawl/blob/8163d8a/crawl-ref/source/mon-act.cc#l4161 [^]

(0029263)
neil (administrator)
2015-06-30 17:13

Fixed in trunk (0.17-a0-1461-g78138a9), thanks! I also made fleeing monsters able to similarly chop non-direct-path firewood as a fallback, rather than cowering (0.17-a0-1462-ge08e1a1).
(0029275)
neil (administrator)
2015-07-01 19:07

The fix (but not its extension to fleeing monsters) has been backported to stable (0.16.1-48-gd0d25a5), so will be in 0.16.2.
(0029280)
Ololoev (reporter)
2015-07-02 09:04

okeeee!

- Issue History
Date Modified Username Field Change
2015-06-30 15:43 Ololoev New Issue
2015-06-30 15:49 wheals Description Updated
2015-06-30 16:26 neil Note Added: 0029262
2015-06-30 16:27 neil Note Edited: 0029262
2015-06-30 17:13 neil Note Added: 0029263
2015-06-30 17:13 neil Status new => resolved
2015-06-30 17:13 neil Fixed in Branch => 0.17 development branch
2015-06-30 17:13 neil Resolution open => done
2015-06-30 17:13 neil Assigned To => neil
2015-07-01 19:07 neil Note Added: 0029275
2015-07-01 19:07 neil Fixed in Branch 0.17 development branch => 0.16 pre-release branch
2015-07-02 09:04 Ololoev Note Added: 0029280
2015-07-02 09:04 Ololoev Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker