Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009795 [DCSS] Bug Report minor always 2015-06-19 11:40 2015-07-01 10:26
Reporter savageorange View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.17 ancient branch
Summary 0009795: explore_auto_rest causes bloodless vampire to rest foreverrrrr...
Description .. or rather, until an enemy enters LOS.

Steps to reproduce:
1. Set explore_auto_rest = true in your init.txt or rcfile
2. Start a Vampire. I used Necromancer background because casting hunger.
3. Become bloodless (by spellcasting a lot and avoiding melee, for example)
4. Get injured
5. Press o to auto-explore
6. You will probably be interrupted by an enemy after many turns. Note the 'time taken for last action' figure -- in my case, it was 948.0.

Suggested fix:
If player has the 'does not heal naturally' mutation, auto-rest should only consider MP, not HP. If I understand correctly, this would also remove the need for the current special-casing for DD.

Pointed out by Sprucery on Tavern and verified by me.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0029267)
savageorange (reporter)
2015-07-01 08:44

Neil just fixed this : https://github.com/crawl/crawl/commit/474c87db9304 [^]
So it should be closable now.

- Issue History
Date Modified Username Field Change
2015-06-19 11:40 savageorange New Issue
2015-07-01 08:44 savageorange Note Added: 0029267
2015-07-01 10:25 MarvinPA Status new => resolved
2015-07-01 10:25 MarvinPA Fixed in Branch => 0.16 pre-release branch
2015-07-01 10:25 MarvinPA Resolution open => done
2015-07-01 10:25 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker