Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009763 [DCSS] Bug Report minor have not tried 2015-06-10 15:09 2016-01-02 11:50
Reporter Gorice View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.17 ancient branch
Summary 0009763: Items not yet recognised list displays known items rather than unkown items
Description Actually playing webtiles on project357.org but no option in above list.

When accessing the items recognised/not yet recognised list using backslash (\) then pressing minus (-) to show items not yet identified/recognised the unrecognised items list shows the already recognised items, not the unrecognised items.
Additional Information
Tags No tags attached.
Attached Files png file icon unknown_scrolls.png [^] (169,822 bytes) 2015-06-10 15:40
png file icon known_scrolls.png [^] (180,613 bytes) 2015-06-10 15:40
png file icon unknown_potions.png [^] (246,901 bytes) 2015-06-10 15:50
png file icon known_potions.png [^] (253,545 bytes) 2015-06-10 15:50

- Relationships

-  Notes
(0029156)
Gorice (reporter)
2015-06-10 15:17

Sorry investigated further:
It appears to be just the scrolls and potions categories where there is a problem and for these two categories the unrecognised list (\-) seems currently just to list all possible potions/scrolls rather than just the unrecognised ones. Staves, jewellery and books look OK.
(0029158)
neil (administrator)
2015-06-10 15:24

Could you include a screenshot of the relevant part of each list (recognised and unrecognised), showing the scrolls/potions that are listed on both?
(0029159)
Gorice (reporter)
2015-06-10 15:43
edited on: 2015-06-10 15:51

OK I've uploaded screenshots showing my known- and unknown- scrolls lists. Note that most scrolls appear on both lists! I think the unknown list is in fact just a list of all possible scrolls. The situation is the same for potions but AFAICS not for the other categories which are still OK.

Edit: Known/unknown potions screenshots now added.

(0029160)
MarvinPA (developer)
2015-06-10 17:07

This sounds like something I probably broke with identification state changes? Will take a look into it later.
(0029161)
neil (administrator)
2015-06-10 17:43

Aha, that's why I couldn't reproduce it---I didn't have MarvinPA's commits yet. Fixed in trunk (0.17-a0-1340-g19d3fa4), thanks!

- Issue History
Date Modified Username Field Change
2015-06-10 15:09 Gorice New Issue
2015-06-10 15:17 Gorice Note Added: 0029156
2015-06-10 15:18 neil Note Added: 0029157
2015-06-10 15:21 neil Note Deleted: 0029157
2015-06-10 15:24 neil Note Added: 0029158
2015-06-10 15:40 Gorice File Added: unknown_scrolls.png
2015-06-10 15:40 Gorice File Added: known_scrolls.png
2015-06-10 15:43 Gorice Note Added: 0029159
2015-06-10 15:50 Gorice File Added: unknown_potions.png
2015-06-10 15:50 Gorice File Added: known_potions.png
2015-06-10 15:51 Gorice Note Edited: 0029159
2015-06-10 17:07 MarvinPA Note Added: 0029160
2015-06-10 17:08 MarvinPA Issue Monitored: MarvinPA
2015-06-10 17:43 neil Note Added: 0029161
2015-06-10 17:43 neil Status new => resolved
2015-06-10 17:43 neil Fixed in Branch => 0.17 development branch
2015-06-10 17:43 neil Resolution open => done
2015-06-10 17:43 neil Assigned To => neil
2016-01-02 11:50 Gorice Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker