Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009747 [DCSS] Bug Report text have not tried 2015-05-29 02:54 2015-07-14 20:27
Reporter noobcanoe View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.17 ancient branch
Summary 0009747: NO GOD placeholder in anubis guard ally flavor text
Description Started as HOCK, worshipped Beogh. Got an orc knight follower and Xom's power touched him, so it became an anubis guard. Anubis guard casts Dispel Undead on a shadow:

Xom's attention turns to you for a moment.
Flickering shadows surround you.
There are monsters nearby!
You hit the shadow.
The shadow is lightly damaged.
Your anubis guard mumbles some strange prayers to NO GOD against the shadow.
The shadow convulses!
The shadow is destroyed!
The shadow closely misses you.
Your anubis guard calls down the wrath of NO GOD upon the shadow.
The shadow convulses!
The shadow is destroyed!

Game is current, morgue here: http://dobrazupa.org/morgue/noobcanoe/noobcanoe.txt [^]
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0029114)
PleasingFungus (administrator)
2015-05-29 03:14

Placeholder isn't really the term. Your orc knight was one of the one in seven orcs that are atheists, so it had no god to use for its new priest powers.

Possibly atheists shouldn't be allowed to use priestly abilities?
(0029115)
I want to believe (reporter)
2015-05-29 11:17

I think it'd be more fair to polymorphed orcs to just not have any atheistic orcs in your army, after all, they are supposed to be following you as Beogh's messiah. Making all friendly orcs change their god to Beogh could be a solution, if its not anymore of a hassle to code than another solution.
(0029117)
PleasingFungus (administrator)
2015-05-29 17:02

That doesn't really solve the problem; it's perfectly possible to have atheists (aka most non-orcs) polymorphed into anubis guards *without* beogh being involved at all.
(0029119)
MarvinPA (developer)
2015-05-30 23:19
edited on: 2015-05-30 23:20

I guess anubis guards are actually the only priestly monsters that are valid polymorph targets currently, seems better to just give them M_NO_POLY_TO than to allow monsters to poly into a weird not-really-an-anubis-guard that can't use its abilities. Alternatively monsters polying into priests could get converted to GOD_NAMELESS I suppose.

It does look like all orcish followers are made to worship Beogh even if they started out athiest though, so I don't know how this actually happens as reported.

(0029120)
neil (administrator)
2015-05-31 01:15

Orcs of Beogh turn atheist when polymorphed into non-Orcs, since Beogh is racist and all. In change_monster_type():
    const god_type god =
        (player_will_anger_monster(real_targetc)
            || (you_worship(GOD_BEOGH)
                && mons_genus(real_targetc) != MONS_ORC)) ? GOD_NO_GOD
                                                          : mons->god;
(0029313)
MarvinPA (developer)
2015-07-14 20:27

Monsters polymorphed into priests now get converted to GOD_NAMELESS (hopefully nobody adds any priests of specific gods that are also valid poly targets).

- Issue History
Date Modified Username Field Change
2015-05-29 02:54 noobcanoe New Issue
2015-05-29 03:14 PleasingFungus Note Added: 0029114
2015-05-29 11:17 I want to believe Note Added: 0029115
2015-05-29 17:02 PleasingFungus Note Added: 0029117
2015-05-30 23:19 MarvinPA Note Added: 0029119
2015-05-30 23:20 MarvinPA Note Edited: 0029119
2015-05-31 01:15 neil Note Added: 0029120
2015-06-29 19:10 MarvinPA Issue Monitored: MarvinPA
2015-07-14 20:27 MarvinPA Note Added: 0029313
2015-07-14 20:27 MarvinPA Status new => resolved
2015-07-14 20:27 MarvinPA Fixed in Branch => 0.16 pre-release branch
2015-07-14 20:27 MarvinPA Resolution open => done
2015-07-14 20:27 MarvinPA Assigned To => MarvinPA
2015-07-14 20:28 MarvinPA Issue End Monitor: MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker