Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009739 [DCSS] Bug Report minor sometimes 2015-05-23 01:52 2016-09-15 00:48
Reporter amalloy View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status closed   Product Branch 0.17 ancient branch
Summary 0009739: Weird 3x3 splotches on my map
Description Save file: http://crawl.akrasiac.org/saves/amalloy-crawl-git-0372368345-150522-1940.tar.bz2 [^]

Look at the level maps for O:1, P:3, and P:4. There are these weird 3x3 squares of areas that I somehow know to be rock walls, even though I obviously can't have ever seen there, and even ?mapping wouldn't fill those spots in. On P:3, for example, it's in the southeast corner.

I can produce these spots, one per floor, semi-reliably but not 100% of the time. The steps that I followed to produce the spots on P:4 and O:1, after accidentally doing it on P:3, are as follows (and of course I don't know which of these steps are strictly necessary):

1. Leave the floor. It doesn't seem to work for the floor you're currently on, but any other floor is fine.
2. Open up the level map for the target floor, with e.g. XGO2.
3. Move the cursor to a known rock wall (not sure about this, maybe any tile is fine)
4. Hold down the v key for a few seconds, causing the screen to quickly flicker between describing the rock wall and showing the map.
5. Look around on the level map: there may (again, not 100% reliably able to reproduce) be a new 3x3 splotch "explored" in the periphery of the map where players can't go without digging.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0010670closedPleasingFungus Map knowledge revealed without having to explore it 

-  Notes
(0031011)
PleasingFungus (administrator)
2016-09-15 00:47

Fixed in 5fe9782d6050f, probably.

- Issue History
Date Modified Username Field Change
2015-05-23 01:52 amalloy New Issue
2016-09-13 07:01 amalloy Relationship added duplicate of 0010670
2016-09-15 00:47 PleasingFungus Note Added: 0031011
2016-09-15 00:47 PleasingFungus Status new => resolved
2016-09-15 00:47 PleasingFungus Resolution open => done
2016-09-15 00:47 PleasingFungus Assigned To => PleasingFungus
2016-09-15 00:48 amalloy Status resolved => closed
2016-09-15 00:48 amalloy Fixed in Branch => 0.19 development branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker