Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009729 [DCSS] Bug Report crash always 2015-05-18 16:20 2015-05-19 07:30
Reporter Le_Nerd View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.17 ancient branch
Summary 0009729: On a felid in ten-rune challenge game crashes in hell
Description http://crawl.develz.org/saves/dumps/Svalbardcaretaker-sprint-243345b-150518-1418.cs [^]


Playing a Felid of Ru, entering a certain door in hells (the one I am standing in front of in the safe game) crashes the game. No clue whats causing it.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0029064)
Le_Nerd (reporter)
2015-05-18 16:29

Oh and I just noticed that part of the level was reset. All the monsters were asleep again, map was undiscovered etc.
(0029069)
MarvinPA (developer)
2015-05-18 19:05

I expect it's caused by acq_on_sight(_G, '$', {"armour","armour"}).
(0029071)
PleasingFungus (administrator)
2015-05-19 07:30

Fixed-ish in 9903972, thanks!

- Issue History
Date Modified Username Field Change
2015-05-18 16:20 Le_Nerd New Issue
2015-05-18 16:29 Le_Nerd Note Added: 0029064
2015-05-18 19:05 MarvinPA Note Added: 0029069
2015-05-19 07:30 PleasingFungus Note Added: 0029071
2015-05-19 07:30 PleasingFungus Status new => resolved
2015-05-19 07:30 PleasingFungus Fixed in Branch => 0.16 pre-release branch
2015-05-19 07:30 PleasingFungus Resolution open => done
2015-05-19 07:30 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker