Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009689 [DCSS] Bug Report text always 2015-04-29 02:51 2016-09-19 16:48
Reporter johnnyzero View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.17 ancient branch
Summary 0009689: Inaccurate memorization failure messages for summoning spells under Sacrifice Love
Description When attempting to memorize a from a spellbook completely barred by Ru spell school sacrifices, the failure message blames race instead of the actual reason.

While worshiping Ru, sacrificed some schools of magic including summonings. While trying to memorize from a book of callings, received the message:
You cannot memorize any of the available spells because you are a White
Draconian.


Save: https://dobrazupa.org/saves/johnnyzero-crawl-git-4a4ba729c9-150429-0049.tar.bz2 [^]
(Character is on top of a book, hit 'M')
Additional Information
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0009707closedneil Wrong reasoning for spell memorization refusal 

-  Notes
(0028989)
johnnyzero (reporter)
2015-04-29 03:13
edited on: 2015-04-29 04:08

This bug report is the real thing that's inaccurate!

Spell memorization denials due to sacrificed spell schools *have correct messages*.

The mentioned character does *not* have summonings as one of its sacrificed schools, but it *does* have sacrifice love. Sacrifice love looks to be the real culprit.

Can a developer please update this bug's title?

edit: Additional information/clarification.

(0029017)
wheals (administrator)
2015-05-06 18:20

Should be fixed by https://github.com/crawl/crawl/commit/3e962ac8c6e2. [^]

- Issue History
Date Modified Username Field Change
2015-04-29 02:51 johnnyzero New Issue
2015-04-29 03:13 johnnyzero Note Added: 0028989
2015-04-29 03:59 wheals Summary Inaccurate memorization failure messages for Ru-sacrificed spell schools. => Inaccurate memorization failure messages for summoning spells under Sacrifice Love
2015-04-29 04:08 johnnyzero Note Edited: 0028989
2015-05-06 18:16 neil Relationship added has duplicate 0009707
2015-05-06 18:20 wheals Note Added: 0029017
2015-05-06 18:20 wheals Status new => resolved
2015-05-06 18:20 wheals Fixed in Branch => 0.16 pre-release branch
2015-05-06 18:20 wheals Resolution open => done
2015-05-06 18:20 wheals Assigned To => wheals
2016-09-19 16:48 johnnyzero Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker