Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009666 [DCSS] Bug Report minor always 2015-04-21 17:48 2015-04-22 16:59
Reporter Kvaak View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.17 ancient branch
Summary 0009666: Ashenzari's skill boost does not stack with Fencer's gloves.
Description Base long blades skill: 13.5
Long blades without cursing the weapon, wearing the gloves: 17.5
Long blades with a cursed weapon, no gloves: 18.1
Long blades with both gloves and cursed weapon: 18.1

I'm not particularly fond of the idea of dumping my piety but I'd assume larger of the two takes precedence.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0028944)
Kvaak (reporter)
2015-04-21 17:57

Correction: ash boost simply overrides the gloves regardless of which boost is larger.
(0028945)
wheals (administrator)
2015-04-21 18:02

For anyone who wants to fix this, this is because in player::skill, the Ash boost simply nukes any skill changes made earlier in the function. A refactor might also be able to get rid of the weird recursive call when you're drained, by just moving the drain calculation to the end.
(0028960)
wheals (administrator)
2015-04-22 16:59

Fixed in https://github.com/crawl/crawl/commit/f0ac9f8d5d67 [^] (though I wasn't sure enough about the code to do refactoring).

- Issue History
Date Modified Username Field Change
2015-04-21 17:48 Kvaak New Issue
2015-04-21 17:57 Kvaak Note Added: 0028944
2015-04-21 18:02 wheals Note Added: 0028945
2015-04-22 16:59 wheals Note Added: 0028960
2015-04-22 16:59 wheals Status new => resolved
2015-04-22 16:59 wheals Fixed in Branch => 0.16 pre-release branch
2015-04-22 16:59 wheals Resolution open => done
2015-04-22 16:59 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker