Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009624 [DCSS] Bug Report minor always 2015-04-09 23:31 2015-04-15 17:00
Reporter Xentronium View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.17 ancient branch
Summary 0009624: Wand of enslavement doesn't display success %
Description Some wands display the chance of beating enemy MR, some do not. Eg from my current game:

Zapping: p - a wand of enslavement (8)
 Press: ? - help, Shift-Dir - straight line, f - swamp dragon
 Aim: a swamp dragon (water)
Zapping: x - a wand of disintegration (6)
 Press: ? - help, Shift-Dir - straight line, f - swamp dragon
 Aim: a swamp dragon (water, chance 73%)
Zapping: x - a wand of disintegration (6)
 Press: ? - help, Shift-Dir - straight line, f - swamp dragon
 Aim: a swamp dragon (water, chance 73%)
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0028868)
neil (administrator)
2015-04-14 23:38

Caused by the removal of Enslavement (in particular, the entry in _spl_zaps)
(0028875)
wheals (administrator)
2015-04-15 17:00

Fixed in https://github.com/crawl/crawl/commit/949c2d44487f. [^]

|amethyst: I assume you didn't do the change yourself because, as you mentioned on IRC, you wanted to make it a flag on the zap instead? That does have the issue that currently zap-less spells (such as Mass Confusion) have the success chance shown on monster spell xv, so it can't be just in the zap. Also, I think a better long-term goal would be to merge zaps into spells, anyway.

- Issue History
Date Modified Username Field Change
2015-04-09 23:31 Xentronium New Issue
2015-04-14 23:38 neil Note Added: 0028868
2015-04-14 23:39 neil Summary Some wands don't display success % => Wand of enslavement doesn't display success %
2015-04-15 17:00 wheals Note Added: 0028875
2015-04-15 17:00 wheals Status new => resolved
2015-04-15 17:00 wheals Fixed in Branch => 0.16 pre-release branch
2015-04-15 17:00 wheals Resolution open => done
2015-04-15 17:00 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker