Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000961 [DCSS] Bug Report trivial have not tried 2010-02-27 18:47 2013-08-11 17:52
Reporter qui View Status public  
Assigned To Medar
Priority normal Resolution done  
Status resolved   Product Branch 0.6 ancient branch
Summary 0000961: Wrong message order when monster appears
Description Messages when a kobold appeared in front of me (probably stepped into tele trap):
_A kobold comes into view. A kobold appears from thin air!

I think they either should appear in reverse order or only the second one should appear.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0003098)
rob (developer)
2010-02-27 19:26

Was this on cdo? Could you point to the game, and ideally the rough place it happened? I'd like to have a look at the ttyrec.
(0003107)
rob (developer)
2010-02-27 23:13

Got this myself just now, with a killer bee while resting. I think this is not wrong message order, but duplicate "comes into view" messages. It should be just "appears from thin air".
(0003111)
due (developer)
2010-02-28 00:02

This is an issue with seen contexts that I've run into before. I made a rather hack-y tweak to the map code to allow a "seen" tag to be applied to monsters, specifically those spawning with dgn.create_monster (see the Wucad Mu WizLab) that prevents this message (but nothing else) and allows a custom message to be printed instead. It may be that the seen context flag needs to be applied to monsters that teleport in front of the player, I think it's MF_WAS_SEEN, but there is slightly more to it than just that, which I can't remember off the tpo of my head.
(0023687)
chris (updater)
2013-08-08 20:36

I cannot reproduce this in current crawl. Unseen monsters wandering into a tele trap only give "appears from thin air" here in a test vault.
(0023708)
Medar (developer)
2013-08-11 17:52

Resolving this as per chris' comment. If this still happens, please reopen.

- Issue History
Date Modified Username Field Change
2010-02-27 18:47 qui New Issue
2010-02-27 19:26 rob Note Added: 0003098
2010-02-27 23:13 rob Note Added: 0003107
2010-02-27 23:13 rob Status new => confirmed
2010-02-28 00:02 due Note Added: 0003111
2013-08-08 20:36 chris Note Added: 0023687
2013-08-11 17:52 Medar Note Added: 0023708
2013-08-11 17:52 Medar Status confirmed => resolved
2013-08-11 17:52 Medar Fixed in Branch => 0.13 development branch
2013-08-11 17:52 Medar Resolution open => done
2013-08-11 17:52 Medar Assigned To => Medar


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker