Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009608 [DCSS] Bug Report crash always 2015-04-03 17:31 2015-04-16 23:08
Reporter thrig View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0009608: multi-wand purchase-IDing results in negative gold
Description Have 100 gold.

There are two 50 gold unidentified wands in a store.

Purchase both wands.

Exit store, crawl will crash due to negative gold, presumably due to the first wand having been ID'd, and the second wand now ringing in at a higher price. To fix, must either offer both at the initial discount (good for the player), or somehow back into a "whoa, you don't have enough gold!" with the second wand now ID'd in the store inventory.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0028886)
wheals (administrator)
2015-04-16 23:08

Fixed in https://github.com/crawl/crawl/commit/00468da8c818, [^] thanks for reporting!

- Issue History
Date Modified Username Field Change
2015-04-03 17:31 thrig New Issue
2015-04-16 23:08 wheals Note Added: 0028886
2015-04-16 23:08 wheals Status new => resolved
2015-04-16 23:08 wheals Fixed in Branch => 0.16 pre-release branch
2015-04-16 23:08 wheals Resolution open => done
2015-04-16 23:08 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker