Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009591 [DCSS] Bug Report crash always 2015-03-29 04:51 2015-07-01 19:04
Reporter chikinn View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0009591: Core dump when starting a new game
Description My last character was an ogre arcane marksman. As usual... he died. Upon starting a new game, I selected the same species and background, and immediately crashed before the first level was generated. This happened several times in a row. I'm attaching two example crash reports.

For kicks, I switched to human berserker, and the game started normally. Then, I tried ogre arcane marksman again, and it started normally.
Additional Information
Tags No tags attached.
Attached Files txt file icon crash--20150328-224755.txt [^] (4,820 bytes) 2015-03-29 04:51 [Show Content]
txt file icon crash--20150328-224639.txt [^] (4,820 bytes) 2015-03-29 04:52 [Show Content]
txt file icon crash--20150425-135354.txt [^] (4,497 bytes) 2015-04-25 22:08 [Show Content]

- Relationships
has duplicate 0009745resolvedPleasingFungus Kobold Hunter Closes Window 
has duplicate 0009464resolvedwheals Crash on character creation when using the trunk windows installer. 
has duplicate 0009786resolvedwheals DCSS crashes when selecting Hunter background 
has duplicate 0009830closedneil After playing 1 game, game crashes after background is chosen 

-  Notes
(0028733)
chikinn (reporter)
2015-03-29 04:53

Forgot to mention, I'm running Arch Linux.
(0028734)
chikinn (reporter)
2015-03-29 04:57

It seems to be happening for other arcane marksmen starts too. The crash is before I select a weapon.
(0028745)
Frenoss (reporter)
2015-03-31 03:42

I hit 8577, which had similar symptoms. You might be able to work around the problem by following the same steps neil sent me: remove any line setting the "weapon = " option in your rc file or delete the start-ns.prf file.

The problem looks to be referring to a weapon subtype or property type that is beyond any the game knows of, in itemprop.cc weapon_base_name().
(0028747)
chikinn (reporter)
2015-03-31 15:26

Thanks!
(0028829)
Abradox (reporter)
2015-04-10 22:49

I had the same issue when i was trying to choose "centaur hunter". (There was one saved game). Then i choose another race and background and this problem has gone. Ubuntu, 0.16.1
(0028975)
Hobgoblinbutter (reporter)
2015-04-25 22:07
edited on: 2015-04-25 22:07

I also ran into this bug. It crashed when I started a Demonspawn Hunter. The common denominator here looks to be the hunter/marksman class, regardless of race. Picking "Demonspawn Fighter" but backing out at the weapon selection screen and going back to "Demonspawn Hunter" caused the bug to disappear without restarting the game. Guess I should mention I'm on Windows 7 64bit.

(0029052)
andrew (reporter)
2015-05-12 20:46

I had the same thing happen to me. Was trying to play HaHu, last game was OgHu.
(0029186)
Gunthar (reporter)
2015-06-17 22:36

Issue still existing. Attempting to play KoHu causes the game to crash before weapon selection.
(0029272)
neil (administrator)
2015-07-01 19:04

Fixed in trunk (0.17-a0-1473-gfb315ab) and stable (0.16.1-51-g6203257), thanks!

The problem was when we tried to look up the name for the fake WPN_THROWN we use to record weapon choice, so it only happened if you chose a throwing hunter in your previous game.

- Issue History
Date Modified Username Field Change
2015-03-29 04:51 chikinn New Issue
2015-03-29 04:51 chikinn File Added: crash--20150328-224755.txt
2015-03-29 04:52 chikinn File Added: crash--20150328-224639.txt
2015-03-29 04:53 chikinn Note Added: 0028733
2015-03-29 04:57 chikinn Note Added: 0028734
2015-03-31 03:42 Frenoss Note Added: 0028745
2015-03-31 03:42 Frenoss Issue Monitored: Frenoss
2015-03-31 15:26 chikinn Note Added: 0028747
2015-04-10 22:49 Abradox Note Added: 0028829
2015-04-25 22:07 Hobgoblinbutter Note Added: 0028975
2015-04-25 22:07 Hobgoblinbutter Note Edited: 0028975
2015-04-25 22:08 Hobgoblinbutter File Added: crash--20150425-135354.txt
2015-05-12 20:46 andrew Note Added: 0029052
2015-05-27 20:24 PleasingFungus Relationship added has duplicate 0009745
2015-05-27 21:39 wheals Relationship added has duplicate 0009464
2015-06-15 14:05 wheals Relationship added has duplicate 0009786
2015-06-17 22:36 Gunthar Note Added: 0029186
2015-06-17 22:41 Gunthar Issue Monitored: Gunthar
2015-07-01 18:03 wheals Relationship added has duplicate 0009830
2015-07-01 18:34 neil Status new => assigned
2015-07-01 18:34 neil Assigned To => neil
2015-07-01 19:04 neil Note Added: 0029272
2015-07-01 19:04 neil Status assigned => resolved
2015-07-01 19:04 neil Fixed in Branch => 0.16 pre-release branch
2015-07-01 19:04 neil Resolution open => done


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker