Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009588 [DCSS] Bug Report crash have not tried 2015-03-28 21:59 2016-01-06 01:46
Reporter chikinn View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0009588: Core dump while targeting rod of iron
Description I was aiming a rod of iron at a group of kobolds. I had successfully aimed and used this rod several times already. Running Arch Linux.

Error message follows:
=====
ASSERT(in_diamond_int(r->start)) in 'ray.cc' at line 166 failed.

We crashed! This is likely due to a bug in Crawl. Please submit a bug report at https://crawl.develz.org/mantis/ [^] and include the crash report, your save file, and a description of what you were doing when this crash occurred.

Aborted (core dumped)
=====
Additional Information
Tags No tags attached.
Attached Files txt file icon crash-chikinn2-20150328-165323.txt [^] (47,024 bytes) 2015-03-28 21:59 [Show Content]
? file icon chikinn2.cs [^] (307,192 bytes) 2015-03-28 22:00

- Relationships

-  Notes
(0030116)
neil (administrator)
2016-01-06 01:46

Probably fixed in trunk (0.18-a0-1002-ged0b5f8), thanks!

While the underlying rounding problem might still exist, it appeared to only trigger when the ray's direction vector was relatively large, which happened because of the error fixed in the cited commit.

- Issue History
Date Modified Username Field Change
2015-03-28 21:59 chikinn New Issue
2015-03-28 21:59 chikinn File Added: crash-chikinn2-20150328-165323.txt
2015-03-28 22:00 chikinn File Added: chikinn2.cs
2015-03-28 23:22 chikinn Issue Monitored: chikinn
2016-01-06 01:46 neil Note Added: 0030116
2016-01-06 01:46 neil Status new => resolved
2016-01-06 01:46 neil Fixed in Branch => 0.18 development branch
2016-01-06 01:46 neil Resolution open => done
2016-01-06 01:46 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker