Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009512 [DCSS] Bug Report minor have not tried 2015-03-02 18:01 2015-03-12 00:03
Reporter Sandman25 View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.16 ancient branch
Summary 0009512: Blowgun does not respect !f inscription
Description Not sure if it is a bug or feature request but !f inscription is ignored on blowguns.
I have an artefact blowgun with speed and rElec, I am with Chei and want to be able to wield the blowgun and get a confirmation "Really fire with blowgun? y/N" when shooting needles.
Inscribing needles is not a good idea as I have a normal blowgun also.
I tried !* !f !F !a =F =* =f also.
Additional Information
Tags patch
Attached Files ? file icon 9512.patch [^] (923 bytes) 2015-03-04 03:18 [Show Content]
? file icon 2-9512.patch [^] (957 bytes) 2015-03-05 16:34 [Show Content]

- Relationships

-  Notes
(0028599)
ebering (developer)
2015-03-04 03:19

Attached patch fixes. Makes !f and !* confirm firing when using the inscribed launcher to fire. !a is for melee attacks, and probably there needs to be a manual edit to clarify that.
(0028604)
ebering (developer)
2015-03-05 16:34

Improved the patch to not dereference a possibly null pointer and use is_launched correctly, since is_launched isn't a boolean function!!!!!
(0028633)
wheals (administrator)
2015-03-11 21:33

Committed into 0.16 and trunk by neil, thanks!
(0028634)
Sandman25 (reporter)
2015-03-12 00:03

Thanks!

- Issue History
Date Modified Username Field Change
2015-03-02 18:01 Sandman25 New Issue
2015-03-04 03:18 ebering File Added: 9512.patch
2015-03-04 03:19 ebering Note Added: 0028599
2015-03-05 16:34 ebering File Added: 2-9512.patch
2015-03-05 16:34 ebering Note Added: 0028604
2015-03-11 07:27 neil Tag Attached: patch
2015-03-11 21:33 wheals Note Added: 0028633
2015-03-11 21:33 wheals Status new => resolved
2015-03-11 21:33 wheals Fixed in Branch => 0.16 pre-release branch
2015-03-11 21:33 wheals Resolution open => done
2015-03-11 21:33 wheals Assigned To => wheals
2015-03-12 00:03 Sandman25 Note Added: 0028634
2015-03-12 00:03 Sandman25 Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker