Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009485 [DCSS] Bug Report minor random 2015-02-13 02:10 2016-01-30 02:25
Reporter Jarlyk View Status public  
Assigned To wheals
Priority normal Resolution duplicate  
Status closed   Product Branch 0.16 ancient branch
Summary 0009485: UI occassionally responds as if "Shift" key held down
Description For a few months know playing with 0.16, I've noticed that occasionally the system will behave as if the "Shift" key is held down. When this happens, all subsequent key presses will act as if modified by Shift. This can be resolved by hitting the Shift key once, which causes the system to return to normal behavior.

I haven't noticed any particular pattern in when this occurs, but it happens at least once every fifteen minutes or so. It was just under the annoyance threshold to letting it bother me, but just noticed that someone mentioned a similar issue on the tavern: https://crawl.develz.org/tavern/viewtopic.php?f=9&t=14904&p=207533#p207533 [^]

Running Windows 8.1
Using a Logitech G110 keyboard
Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0009543resolvedwheals UI occassionally responds as if "Ctrl" key held down 

-  Notes
(0028590)
tsohg (reporter)
2015-03-02 02:30

I am having similar issues on Mac OS X 10.10.2 (macbook pro retina) in 0.16, I noticed the problem start cropping up in mid-February and now again in 0.16-a0-4125-g75a0564.

The symptom is mouse clicks in the inventory screen stop responding. (roughly every 5-15 minutes) clicks elsewhere seem to work. I can clear up the problem by pressing CTRL (pressing ALT or SHIFT doesn't help). The odd thing is even though hitting CTRL fixes the problem, crawl isn't acting like CTRL is being held down.

- Issue History
Date Modified Username Field Change
2015-02-13 02:10 Jarlyk New Issue
2015-03-02 02:30 tsohg Note Added: 0028590
2015-07-01 13:00 wheals Relationship added duplicate of 0009543
2015-07-01 13:00 wheals Duplicate ID 0 => 9543
2015-07-01 13:00 wheals Status new => resolved
2015-07-01 13:00 wheals Fixed in Branch => 0.16 pre-release branch
2015-07-01 13:00 wheals Resolution open => duplicate
2015-07-01 13:00 wheals Assigned To => wheals
2016-01-30 02:25 Jarlyk Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker