Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009460 [DCSS] Patches minor have not tried 2015-01-30 06:53 2015-01-31 22:21
Reporter chris View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch experimental branch
Summary 0009460: Show travel exclusions in terrain view and optionally in viewport
Description
Show travel exclusions on | terrain view

--

New option: always_show_exclusions (display exclusions in viewport)

If true, display travel exclusions and their exclusion radius in
the viewport. Exclusions are always visible on the level map
(access with X) regardless of the value of this option.

Exclusions are also visible in terrain-only mode (access with |).


The new option is enabled by default. Terrain mode will always show exclusions and has no option added to disable this behavior.
Cycling through exclusion radius states is made much more comfortable if setting exclusions from viewport (as opposed to X map, which is unchanged) with the new direct feedback.
Quickly checking a monster's LOS is also much easier if all relevant actions can be performed from, and checked in, the viewport. Right now you need to go through X map in cumbersome ways to obtain this information, which is not a great workflow at all.

Please note that these changes have only been tested in console, and I'm not sure how they will affect webtiles or local tiles.
Additional Information
Tags No tags attached.
Attached Files ? file icon show-exclusions.patch [^] (6,743 bytes) 2015-01-30 06:53 [Show Content]

- Relationships

-  Notes
(0028414)
MarvinPA (developer)
2015-01-31 22:21

Pushed, thanks! I'm reasonably sure it should work right in webtiles (displaying exclusions with tile_display_mode = glyph or hybrid, and not doing anything in the standard display mode since that already shows exclusions).

- Issue History
Date Modified Username Field Change
2015-01-30 06:53 chris New Issue
2015-01-30 06:53 chris File Added: show-exclusions.patch
2015-01-30 15:05 MarvinPA Issue Monitored: MarvinPA
2015-01-31 22:21 MarvinPA Note Added: 0028414
2015-01-31 22:21 MarvinPA Status new => resolved
2015-01-31 22:21 MarvinPA Fixed in Branch => 0.16 development branch
2015-01-31 22:21 MarvinPA Resolution open => done
2015-01-31 22:21 MarvinPA Assigned To => MarvinPA
2015-02-01 00:46 MarvinPA Issue End Monitor: MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker