Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009454 [DCSS] Patches feature N/A 2015-01-29 08:27 2015-06-10 18:03
Reporter godzilla View Status public  
Assigned To brendan
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0009454: Ecumenical altars
Description There was a thread on the tavern about altars that convert you to a random god. I wrote a patch implementing this. With it, there's a slightly over 50% chance of such an altar showing up on D1-3. I also included 3 (extremely bland) vaults for it.
This adds a much-requested gameplay feature to the game that can add some controlled randomness to the midgame and could promote unusual playstyles/combinations.
Additional Information
Tags No tags attached.
Attached Files ? file icon altars2.diff [^] (6,937 bytes) 2015-01-30 05:38 [Show Content]
? file icon 0001-Add-ecumenical-altars-bugzilla.patch [^] (7,638 bytes) 2015-06-10 07:29 [Show Content]

- Relationships

-  Notes
(0028401)
neil (administrator)
2015-01-29 23:23
edited on: 2015-01-29 23:35

We discussed this a bit on IRC. The idea is good, but there are some tweaks to make:

 * It shouldn't pick a god you can't worship (function player_can_join_god())
 * We probably don't want altars on D:1 even if they are random.
 * Conversely, it's probably not very interesting past Temple depth.
 * The vault CHANCE:s are way too high, particularly given how many places it can occur. Personally I kind of like the idea of having just one, guaranteed, on D:3 or so, but I don't think there was consensus about that.
 * dpeg said there had been forum talk about a piety bonus like that of monks (but maybe slightly smaller). That would be a good idea, but there are special cases to consider: Ru, Gozag, etc. Probably you could the same things that Monk does for those gods. Lasty suggested +15 or +20 extra piety, so that it's not as good as monk bonus (+35).
 * The altar colour shouldn't be the same as Xom's. I'd suggest something along the lines of ETC_DARK (2/3 darkgrey, 1/3 lightgrey) but that's just bikeshedding.
 * The DNGN_ALTAR_ECUMENICAL enum should come at the very end, after shadow traps. Possibly that was git rebase being too helpful about resolving conflicts :)
 * "Ecumenical altar" was not really liked, but that's bikeshedding and trivial to change.

(0028404)
dpeg (administrator)
2015-01-30 01:01

What Neil said. Except that I am not sure about guaranteed -- at most one (say in the depth range D:2-4) is fine, but I generally like it better when it's a surprise.

Of course, players will want to play "god roulette", and they'll complain if the random altar is not guaranteed. However, especially if this altar gives some additional piety for the gamble, the feature should be random (and perhaps even slightly rare-ish). Otherwise we're risking players rushing through D:3, pick random god and quit if they're unhappy with the result.
(0028405)
godzilla (reporter)
2015-01-30 05:44

neil and dpeg,
Thanks a lot for the replies! I've uploaded an updated version of the patch that (should) fix all the issues.
* The altar is now ETC_DARK
* Moved DNGN_ALTAR_ECUMENICAL to the end of the enum (sorry about that, I thought it should go next to the Ru and Gozag altars)
* The vault now has a much lower CHANCE (5%) and appears only on dungeon levels 2-7 (hopefully)
* You now get 20 piety on joining. Ru gets an immediate sacrifice, and Gozag doesn't have a service fee. The piety is lower than it is for a monk, but the Ru and Gozag bonuses are the same.
* The code now checks player_can_join_god().
I don't really like the idea of it being guaranteed either, TBH, for the reasons dpeg pointed out.
Thanks a lot for taking a look at this!
(0029149)
Rast (reporter)
2015-06-08 05:02

I proposed a similar idea on IRC and the tavern, and PleasingFungus pointed this patch out to me.

My suggestions:
No piety bonus, to make it less scummy (and spoily).
Only appearing on D:2-3, because it's really crappy find compared to the Temple and all the mini-temples scattered on D:4+
If Gozag is rolled, and the player doesn't have enough gold to join, take all he has and let him join anyway.
(0029152)
chequers (reporter)
2015-06-10 07:29

I've updated the patch with several changes & fixes:
* After you pray at this altar it is replaced with the relevant god's altar
* Second example altar
* Moved logic from join_religion (religion.cc) to _altar_pray_or_convert (godprayer.cc)

Spawns 50% of the time on d:2/3 for testing purposes.
(0029153)
chequers (reporter)
2015-06-10 08:16

PR here https://github.com/crawl/crawl/pull/59 [^]
(0029163)
brendan (developer)
2015-06-10 18:03

Merged

- Issue History
Date Modified Username Field Change
2015-01-29 08:27 godzilla New Issue
2015-01-29 08:27 godzilla File Added: altars.diff
2015-01-29 23:23 neil Note Added: 0028401
2015-01-29 23:25 neil Note Edited: 0028401
2015-01-29 23:33 neil Note Edited: 0028401
2015-01-29 23:35 neil Note Edited: 0028401
2015-01-30 01:01 dpeg Note Added: 0028404
2015-01-30 05:38 godzilla File Added: altars2.diff
2015-01-30 05:44 godzilla Note Added: 0028405
2015-02-03 09:51 chris Issue Monitored: chris
2015-02-03 09:52 chris File Deleted: altars.diff
2015-06-08 05:02 Rast Note Added: 0029149
2015-06-10 07:29 chequers Note Added: 0029152
2015-06-10 07:29 chequers File Added: 0001-Add-ecumenical-altars-bugzilla.patch
2015-06-10 08:16 chequers Note Added: 0029153
2015-06-10 18:03 brendan Note Added: 0029163
2015-06-10 18:03 brendan Status new => resolved
2015-06-10 18:03 brendan Fixed in Branch => 0.17 development branch
2015-06-10 18:03 brendan Resolution open => done
2015-06-10 18:03 brendan Assigned To => brendan


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker