Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009448 [DCSS] Bug Report major have not tried 2015-01-27 11:53 2015-03-05 17:02
Reporter Le_Nerd View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0009448: Ancient liches do not see invsibible, altough they should.
Description http://crawl.develz.org/saves/dumps/Svalbardcaretaker-3748f16-150127-1025.tar.bz2 [^]

Mh, strangely they dont see invisible, as in the summary. Dump is provided.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0028373)
waylon531 (reporter)
2015-01-27 18:19

I just tested this in wizmode and looked in the code, it looks like both liches have see invisible.
(0028378)
PleasingFungus (administrator)
2015-01-28 03:11

Save crashes on load for me, unfortunately.

What do you mean by they "don't see invisible"? See invisible isn't listed in their description, they don't act like they can see you when you're invisible, or what?
(0028380)
Le_Nerd (reporter)
2015-01-28 09:46

Although the ancient liches behind the grates had the "see invisible" in their description, they were in fact unable to do so. I was able to invisible-stab both of them. After killing the first one my invisibility timed out, and immediately the second one was able to see me; I turned invisible again, and the ALich got the orange backdrop of "awake, cant see you due to invisibility".
(0028384)
wheals (administrator)
2015-01-28 16:31

I suspect this might have to do with their being ghost_demons; the irreproducibility might be because ghost_demon::see_invis is uninitialised.

It's been pointed out that liches probably do not need to be ghost_demons, nor spellforged servitors.
(0028386)
PleasingFungus (administrator)
2015-01-28 17:54

For what it's worth, there's a related bug for player ghosts, last I checked; they still display the "stabbable" icon when you're invisible, even though they can see you just fine.
(0028605)
wheals (administrator)
2015-03-05 17:02

Should be fixed by https://github.com/crawl-ref/crawl-ref/commit/c0f6fd7959. [^]

- Issue History
Date Modified Username Field Change
2015-01-27 11:53 Le_Nerd New Issue
2015-01-27 18:19 waylon531 Note Added: 0028373
2015-01-28 03:11 PleasingFungus Note Added: 0028378
2015-01-28 09:46 Le_Nerd Note Added: 0028380
2015-01-28 16:31 wheals Note Added: 0028384
2015-01-28 17:54 PleasingFungus Note Added: 0028386
2015-03-05 17:02 wheals Note Added: 0028605
2015-03-05 17:02 wheals Status new => resolved
2015-03-05 17:02 wheals Fixed in Branch => 0.16 pre-release branch
2015-03-05 17:02 wheals Resolution open => done
2015-03-05 17:02 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker