Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009404 [DCSS] Bug Report crash always 2015-01-14 05:13 2016-01-06 01:43
Reporter Xentronium View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0009404: Crash using iron rod
Description Fighting an invisible moth of wrath on Spider 5.
I switched to an iron rod using ' ,
pressed 'v',
got prompted,
pressed 'V',
screen for evocations came up,
game crashed.
Level reset with me at the staircase.

This has happened twice so far.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0028276)
Xentronium (reporter)
2015-01-14 05:14

Character dump: http://dobrazupa.org/morgue/Xen/Xen.txt [^]
(0028277)
neil (administrator)
2015-01-14 05:24
edited on: 2015-01-14 05:25

This happens reliably at certain coordinates on the map. 0.15-a0-1512-gdf1f371 was an attempt to fix this but just made it happen at different coordinates.

It happens when a ray's path gets very close to the corner of a cell: part of the ray code thinks it's on the corner but part knows that it's not.

We only ever see this with rays where the angle is explicitly set in code (cones, scattershot, chaos bouncing when that was a thing). I think if we "snap" these rays to the grid (so they act as though they were targetted at a particular cell) it would prevent the problem (though not exactly "solve" it).

Numerical analysis welcome!

(0030115)
neil (administrator)
2016-01-06 01:43

Probably fixed in trunk (0.18-a0-1002-ged0b5f8), thanks!

While the underlying rounding problem might still exist, it appeared to only trigger when the ray's direction vector was relatively large, which happened because of the error fixed in the cited commit.

- Issue History
Date Modified Username Field Change
2015-01-14 05:13 Xentronium New Issue
2015-01-14 05:14 Xentronium Note Added: 0028276
2015-01-14 05:24 neil Note Added: 0028277
2015-01-14 05:25 neil Note Edited: 0028277
2015-08-20 05:06 neil Relationship added has duplicate 0009919
2015-10-20 04:16 neil Relationship deleted has duplicate 0009919
2016-01-06 01:43 neil Note Added: 0030115
2016-01-06 01:43 neil Status new => resolved
2016-01-06 01:43 neil Fixed in Branch => 0.18 development branch
2016-01-06 01:43 neil Resolution open => done
2016-01-06 01:43 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker