Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009403 [DCSS] Bug Report trivial always 2015-01-14 04:21 2015-06-29 19:01
Reporter Aule View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0009403: Redundant -cTele announcement
Description Upon entering a warped space area (Zig), the following two lines appear in succession:

 You sense the appearance of a powerful magical force which warps space.
 You sense a powerful magical force warping space.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0028368)
Zannick (reporter)
2015-01-27 05:38

The latter message comes from stairs.cc, when entering a level with -cTele. The former comes from set_level_flags which is called when placing vaults or by dng.change_level_flags in lua. So in this case it's called from dat/dlua/ziggurat.lua which sets no_tele_control based on depth.

Arguably it shouldn't trip the check in set_level_flags since the player is not on the level when it is set (given "the appearance of" in the message, similar to "the disappearance of" when TRJ is defeated and no_tele_control is unset).
(0029253)
MarvinPA (developer)
2015-06-29 19:01

Fixed in the best possible way.

- Issue History
Date Modified Username Field Change
2015-01-14 04:21 Aule New Issue
2015-01-27 05:38 Zannick Note Added: 0028368
2015-06-29 19:01 MarvinPA Note Added: 0029253
2015-06-29 19:01 MarvinPA Status new => resolved
2015-06-29 19:01 MarvinPA Fixed in Branch => 0.16 pre-release branch
2015-06-29 19:01 MarvinPA Resolution open => done
2015-06-29 19:01 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker