Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009382 [DCSS] Bug Report minor always 2015-01-05 11:17 2015-01-07 05:50
Reporter johnstein View Status public  
Assigned To gammafunk
Priority normal Resolution done  
Status resolved   Product Branch experimental branch
Summary 0009382: webtiles-changes games.conf.d doesn't work if there are no [[games]] defined in config.toml
Description how to reproduce:

create a config.toml file with NO games defined
create a games.toml file with several games defined
put games.toml in /webserver/games.conf.d

restart webtiles and get these errors:
jmbjr@www: (master *%) ~$ sudo /etc/init.d/webtiles-dev restart
 * Stopping webtiles server webtiles [ OK ]
 * Starting webtiles server webtiles Traceback (most recent call last):
  File "./server.py", line 17, in <module>
    from conf import config
  File "/home/crawl-dev/crawl-dev/DGL/crawl-master/webserver/conf.py", line 298, in <module>
    config = Conf()
  File "/home/crawl-dev/crawl-dev/DGL/crawl-master/webserver/conf.py", line 42, in __init__
    self.init_games()
  File "/home/crawl-dev/crawl-dev/DGL/crawl-master/webserver/conf.py", line 102, in init_games
    self.load_game_conf_dir()
  File "/home/crawl-dev/crawl-dev/DGL/crawl-master/webserver/conf.py", line 152, in load_game_conf_dir
    self.data["games"].append(game)
KeyError: 'games'


Expected Behavior:
seems like I should be able to fully separate all game definitions from the main config.toml file

Current Workaround:
if I define a single game in config.toml (in this case, trunk), then I no longer get the error.

Looks like conf.py may just need to be able to deal with the situation where no games have been loaded from the main config.toml

Additional Information
Tags No tags attached.
Attached Files ? file icon config.toml [^] (3,793 bytes) 2015-01-05 11:17
? file icon games.toml [^] (5,437 bytes) 2015-01-05 11:18

- Relationships

-  Notes
(0028234)
johnstein (reporter)
2015-01-05 11:18

added sample toml files (from dbro)
(0028247)
gammafunk (administrator)
2015-01-07 05:50

Fixed in webtiles-changes (commit listed as 0.16-a0-3606-g309a318), thanks!

- Issue History
Date Modified Username Field Change
2015-01-05 11:17 johnstein New Issue
2015-01-05 11:17 johnstein File Added: config.toml
2015-01-05 11:18 johnstein File Added: games.toml
2015-01-05 11:18 johnstein Note Added: 0028234
2015-01-07 05:50 gammafunk Note Added: 0028247
2015-01-07 05:50 gammafunk Status new => resolved
2015-01-07 05:50 gammafunk Fixed in Branch => 0.16 development branch
2015-01-07 05:50 gammafunk Resolution open => done
2015-01-07 05:50 gammafunk Assigned To => gammafunk


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker