Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009359 [DCSS] Bug Report minor always 2014-12-22 14:10 2015-05-13 23:18
Reporter asdu View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.16 ancient branch
Summary 0009359: [ and ] keys not working correctly in shift-x mode
Description In shift-x mode, [ and ] behave like they do outside shift-x mode and show armour and equipped items respectively instead of going up and down a level like they should. They work correctly in console.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0009306resolvedneil AltGr key combinations broken 

-  Notes
(0028123)
asdu (reporter)
2014-12-22 16:29

It seems the issue is with all characters accessed with Alt Gr (as [ and ] are on the italian layout I use) in contexts where that character corresponds to a different command than it does in the interface's "normal" mode. For example, in wizard mode, @ gives character information instead of setting str dex int.
(0028235)
asdu (reporter)
2015-01-05 14:36

I've updated to to 0.16-a0-3499-gfbbdc41 and now keys that require AltGr (on an italian keyboard, these include [, ], {, }, @ and #) can't be used at all ("Unknown command.").
Again, console works fine.
(0028934)
wheals (administrator)
2015-04-20 19:30

Should have been fixed by https://github.com/crawl/crawl/commit/2bcf425b1330736ed4749f010eac1e268325dd92. [^]

- Issue History
Date Modified Username Field Change
2014-12-22 14:10 asdu New Issue
2014-12-22 16:29 asdu Note Added: 0028123
2015-01-05 14:36 asdu Note Added: 0028235
2015-04-20 19:30 wheals Note Added: 0028934
2015-04-20 19:30 wheals Status new => resolved
2015-04-20 19:30 wheals Fixed in Branch => 0.16 pre-release branch
2015-04-20 19:30 wheals Resolution open => done
2015-04-20 19:30 wheals Assigned To => wheals
2015-04-20 19:31 wheals Relationship added duplicate of 0009306
2015-05-13 23:18 asdu Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker