Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009342 [DCSS] Patches feature N/A 2014-12-19 05:24 2015-01-09 16:29
Reporter Sandman25 View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.16 ancient branch
Summary 0009342: New option fail_severity_to_confirm
Description Default value is
fail_severity_to_confirm=3
It means user will have to confirm casting a spell with corresponding failure severity or higher (3 - displayed in red in spells screen, 2 - light red, 1 - yellow). Other possible values are 0 and -1 (no confirmation in both cases).

Reasoning: I casted a red severity level spell due to Sap Magic in Pan, it is not very convenient to check failure rate before every cast.
Also protects from accidental casting of a spell with 100% failure or not paying enough attention to draining.

Tested without fail_severity_to_confirm in init.txt, with value 3 and red/lightred spell, with value -1 and red spell, with value 2 and yellow/lightred/red spell.
Additional Information
Tags No tags attached.
Attached Files ? file icon failseveritytoconfirm.patch [^] (1,841 bytes) 2014-12-19 05:24 [Show Content]

- Relationships

-  Notes
(0028206)
neil (administrator)
2015-01-03 00:11

In trunk (0.16-a0-3473-g5649082), thanks!

I made a few tweaks:
 * document
 * check earlier in the casting process, before targetting
 * don't prompt for evocations etc. (the same change)
 * use the same adverbs ("very", "quite", "slightly") as the memorisation prompt.
(0028262)
Sandman25 (reporter)
2015-01-09 16:29

Thank you!

- Issue History
Date Modified Username Field Change
2014-12-19 05:24 Sandman25 New Issue
2014-12-19 05:24 Sandman25 File Added: failseveritytoconfirm.patch
2015-01-03 00:11 neil Note Added: 0028206
2015-01-03 00:11 neil Status new => resolved
2015-01-03 00:11 neil Fixed in Branch => 0.16 development branch
2015-01-03 00:11 neil Resolution open => done
2015-01-03 00:11 neil Assigned To => neil
2015-01-09 16:29 Sandman25 Note Added: 0028262
2015-01-09 16:29 Sandman25 Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker