Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009328 [DCSS] Bug Report minor have not tried 2014-12-14 05:59 2014-12-24 21:01
Reporter hurdos View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0009328: No exit from secret room
Description I have used blink to get in secret room, but cannot exit from it.
I provided screen-shot of the situation.
Additional Information
Tags No tags attached.
Attached Files png file icon dcss_0.15.2.png [^] (487,604 bytes) 2014-12-14 05:59

- Relationships

-  Notes
(0028143)
neil (administrator)
2014-12-23 21:28

Was that with a blink scroll or a random blink?
(0028146)
hurdos (reporter)
2014-12-24 06:36

I used a blink scroll assuming that I can exit via stairs or something else (tele).
(0028153)
neil (administrator)
2014-12-24 20:49
edited on: 2014-12-24 21:01

In general, if you control-blink or fly into a vault, all bets are off: we don't try to guarantee anything in that case, under the assumption that, if you took efforts to find a way in, you can find a way out too. Random blink/teleport/shafts/hatches, however, shouldn't drop you in a closet like that, since that isn't really under your control.

BUT, in this case it is a bug in how the vault (lightli_minifort) was placed, and it could indeed trap a player taking a shaft or hatch onto this level.

(0028154)
neil (administrator)
2014-12-24 21:01

Fixed in trunk (0.16-a0-3296-g0629365), thanks!

- Issue History
Date Modified Username Field Change
2014-12-14 05:59 hurdos New Issue
2014-12-14 05:59 hurdos File Added: dcss_0.15.2.png
2014-12-23 21:28 neil Note Added: 0028143
2014-12-24 06:36 hurdos Note Added: 0028146
2014-12-24 20:49 neil Note Added: 0028153
2014-12-24 21:01 neil Note Added: 0028154
2014-12-24 21:01 neil Status new => resolved
2014-12-24 21:01 neil Fixed in Branch => 0.16 development branch
2014-12-24 21:01 neil Resolution open => done
2014-12-24 21:01 neil Assigned To => neil
2014-12-24 21:01 neil Note Edited: 0028153


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker