Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009314 [DCSS] Patches tweak N/A 2014-12-09 18:39 2014-12-21 04:05
Reporter RBrandon View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0009314: [PATCH] Don't let allies cast animate dead while worshiping Beogh.
Description There is a strange anti-synergy that begins to develop when orc wizards grow
up into orc sorcerors. They begin to animate corpses (almost) indiscriminately
and you end up with a massive army of zombies. This is problematic when Beogh
is already the god of *orcish* armies. Zombies frequently get in the way of the
pathing and LOF of your "congregation," forcing you to do tedious juggling just
to do something trivial, like change floors with your current orc pack.

Finally, if anyone wanted to do anything with Beogh resurrection this would be
a prerequisite.

*NOTE* somewhat related to patch: Beogh's description contains the language "strongly dislikes it when you...desecrate orcish remains." Why does this not include necromancy? Beogh is fine with you animating orcs.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Don-t-let-allies-cast-Animate-Dead-while-worshipping.patch [^] (1,311 bytes) 2014-12-09 18:39 [Show Content]

- Relationships

-  Notes
(0028044)
RBrandon (reporter)
2014-12-09 19:16
edited on: 2014-12-09 19:17

If this ends up accepted, go ahead and remove the comment, since Beogh doesn't actually care about that (meant to amend it out). Unless that is a bug. The purpose of the change is to remove obnoxious gameplay rather than preserve flavour anyway.

(0028111)
wheals (administrator)
2014-12-21 04:05

Added, with a more correct comment.

- Issue History
Date Modified Username Field Change
2014-12-09 18:39 RBrandon New Issue
2014-12-09 18:39 RBrandon File Added: 0001-Don-t-let-allies-cast-Animate-Dead-while-worshipping.patch
2014-12-09 19:16 RBrandon Note Added: 0028044
2014-12-09 19:17 RBrandon Note Edited: 0028044
2014-12-20 17:48 MarvinPA Issue Monitored: MarvinPA
2014-12-21 04:05 wheals Note Added: 0028111
2014-12-21 04:05 wheals Status new => resolved
2014-12-21 04:05 wheals Fixed in Branch => 0.16 development branch
2014-12-21 04:05 wheals Resolution open => done
2014-12-21 04:05 wheals Assigned To => wheals
2014-12-22 00:00 MarvinPA Issue End Monitor: MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker