Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009311 [DCSS] Bug Report minor have not tried 2014-12-08 19:29 2015-01-07 02:23
Reporter tasonir View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status closed   Product Branch 0.16 ancient branch
Summary 0009311: Extremely long duration resistance buff
Description While going through pan on my ogre transmuter, I suddenly realized I had the resistance buff, the same as if I had drank a potion of resistance. I am fairly certain I didn't do that, unless I made some severe typo. There are plenty of chaos monsters around, so that's likely what happened, but the bug is that the effect just about wouldn't end. I was under resistance for all of the rest of pan, and into starting the abyss rune. I'd estimate it lasted for around 3000-5000 turns.

I heard Yermak had a similar issue with invis, which obviously has contamination drawbacks, although for it was purely a beneficial bug.

I was playing on mac, CSZO webtiles, and my account there is Tasonir as well. If you want to try to replay the game I think I first got it somewhere between my first and second unique pan lord rune (I got demonic before any of the 4 unique levels this game). Starting from my second pan lord kill should show the buff.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0008289closedgammafunk Very long Invis from cloud of chaos 

-  Notes
(0028039)
PleasingFungus (administrator)
2014-12-08 19:38

Not convinced it's actually related, but I added a link to the old chaos cloud invis bug.
(0028042)
tasonir (reporter)
2014-12-09 01:30

Adding a link to the morgue file, for exact version number [0.16-a0-3008-g8433e14 (webtiles)] and the game's date to make it easier to find later on: http://dobrazupa.org/morgue/tasonir/morgue-tasonir-20141208-034745.txt [^]
(0028054)
twist (reporter)
2014-12-11 18:43

Experiencing same issue. Started in the Pandemonium and has lasted for 3-4 floors already.
(0028056)
wheals (administrator)
2014-12-11 20:37

As I suspected, this was caused by Chaotic Mirror (cast by a chaos champion in Zig:10, a Pan zig level) for tasonir's game; I expect, given that twist was in Pan, that there was the same cause there.
(0028058)
PleasingFungus (administrator)
2014-12-12 02:03

Should be fixed in 0c274cb, thanks!
(0028245)
tasonir (reporter)
2015-01-07 02:23

Thanks for the fix!

- Issue History
Date Modified Username Field Change
2014-12-08 19:29 tasonir New Issue
2014-12-08 19:33 PleasingFungus Relationship added related to 0008289
2014-12-08 19:38 PleasingFungus Note Added: 0028039
2014-12-09 01:30 tasonir Note Added: 0028042
2014-12-11 18:43 twist Note Added: 0028054
2014-12-11 20:37 wheals Note Added: 0028056
2014-12-12 02:03 PleasingFungus Note Added: 0028058
2014-12-12 02:03 PleasingFungus Status new => resolved
2014-12-12 02:03 PleasingFungus Fixed in Branch => 0.16 development branch
2014-12-12 02:03 PleasingFungus Resolution open => done
2014-12-12 02:03 PleasingFungus Assigned To => PleasingFungus
2015-01-07 02:23 tasonir Note Added: 0028245
2015-01-07 02:23 tasonir Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker