Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009307 [DCSS] Bug Report minor always 2014-12-07 02:43 2014-12-08 20:45
Reporter ebering View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status closed   Product Branch 0.16 ancient branch
Summary 0009307: Non-firey flame cloud immune monsters won't enter flame clouds
Description Specifically noticed this with hell-hounds. Attached patch fixes logic in actor_cloud_immune in clouds.cc but that function could maybe use some more love, currently a bunch of special cases.

The logic was also broken for cold/icy. This all happened because monsters are immune at res=3 but players are not.
Additional Information
Tags No tags attached.
Attached Files ? file icon fire-cold-not-afraid.patch [^] (1,275 bytes) 2014-12-07 02:43 [Show Content]

- Relationships

-  Notes
(0028002)
PleasingFungus (administrator)
2014-12-07 18:55

Applied a similar fix. Thanks!

- Issue History
Date Modified Username Field Change
2014-12-07 02:43 ebering New Issue
2014-12-07 02:43 ebering File Added: fire-cold-not-afraid.patch
2014-12-07 18:55 PleasingFungus Note Added: 0028002
2014-12-07 18:55 PleasingFungus Status new => resolved
2014-12-07 18:55 PleasingFungus Fixed in Branch => 0.16 development branch
2014-12-07 18:55 PleasingFungus Resolution open => done
2014-12-07 18:55 PleasingFungus Assigned To => PleasingFungus
2014-12-08 20:45 ebering Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker