Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009306 [DCSS] Bug Report block always 2014-12-07 00:44 2015-03-01 21:46
Reporter szoltomi View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0009306: AltGr key combinations broken
Description Multiple key combinations invoked with altGr (or ctrl+alt) no longer work on hungarian keyboard layout or collide with other keybinds. For example:

> (altGr + y) and < (altGr + í) no longer useable with interlevel travel
\ (altGr + q) collides with suicide character (ctrl+q)
# (altGr + x) does not seem to work altogether

The commands work correctly in console and webtiles modes with the exception of the backslash, due to the collision with the suicide command.
Additional Information
Tags patch
Attached Files txt file icon macro.txt [^] (215 bytes) 2015-02-06 02:13 [Show Content]
? file icon 0001-Don-t-suppress-textinput-events-for-AltGr-9306.patch [^] (1,033 bytes) 2015-02-12 01:57 [Show Content]

- Relationships
has duplicate 0009463closedneil Commands with "Alt Gr" 
has duplicate 0009359closedwheals [ and ] keys not working correctly in shift-x mode 

-  Notes
(0028445)
szoltomi (reporter)
2015-02-06 02:16

I found a workaround for this bug:
I used the in-game keybinding system to rebind the altgr keycombos to dummy commands, then edited the macro.txt to the correct characters. I uploaded the file for reference.
(0028479)
neil (administrator)
2015-02-12 01:58

The attached patch might fix the problem, but I don't have a convenient way to test it.
(0028481)
neil (administrator)
2015-02-12 02:00

Retitled, since this isn't specific to Hungarian
(0028483)
neil (administrator)
2015-02-13 23:35

AltGr (Mode_switch in X) seems to work fine on Linux without the patch. So it appears to be specific to Windows (though OS X is untested).

It was suggested that this might be because of Windows using Ctrl-Alt to represent AltGr.
(0028583)
neil (administrator)
2015-03-01 21:46

Fixed in trunk (0.16-a0-4118-g2bcf425), thanks! Lasty helped test, finding that we needed to check for KMOD_LCTRL|KMOD_RALT rather than KMOD_MODE.

- Issue History
Date Modified Username Field Change
2014-12-07 00:44 szoltomi New Issue
2015-02-06 00:42 neil Severity major => block
2015-02-06 02:13 szoltomi File Added: macro.txt
2015-02-06 02:16 szoltomi Note Added: 0028445
2015-02-12 01:57 neil File Added: 0001-Don-t-suppress-textinput-events-for-AltGr-9306.patch
2015-02-12 01:58 neil Note Added: 0028479
2015-02-12 01:58 neil Tag Attached: patch
2015-02-12 01:59 neil Relationship added has duplicate 0009463
2015-02-12 02:00 neil Note Added: 0028481
2015-02-12 02:00 neil Summary AltGr key combinations broken on hungarian keyboard layout => AltGr key combinations broken
2015-02-13 23:35 neil Note Added: 0028483
2015-03-01 21:46 neil Note Added: 0028583
2015-03-01 21:46 neil Status new => resolved
2015-03-01 21:46 neil Fixed in Branch => 0.16 development branch
2015-03-01 21:46 neil Resolution open => done
2015-03-01 21:46 neil Assigned To => neil
2015-04-20 19:31 wheals Relationship added has duplicate 0009359


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker