Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009304 [DCSS] Bug Report block have not tried 2014-12-06 22:37 2015-05-19 17:50
Reporter Skrybe View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.15 ancient branch
Summary 0009304: Escape hatch led to vault blocked off from rest of level w/ deep water
Description Taking an upwards escape hatch dumped me in a portion of a vault that was blocked off from the rest of the level with deep water. A save is attached. Without flight/tele, I would be stuck. The offending vault is lemuel_reptile_caves, I guess someone needs to take a look at how it can place deep water.
Additional Information
Tags No tags attached.
Attached Files ? file icon Fierabras.cs [^] (776,045 bytes) 2014-12-06 22:37

- Relationships

-  Notes
(0028140)
neil (administrator)
2014-12-23 20:10
edited on: 2014-12-23 20:11

Fixed in trunk (0.16-a0-3277-gf14698b). I fixed the potential disconnections I could find (that vertical path of water should have been shallow given how it was alternating with another passage; and there were a few theoretically-disconnectable spots that in practice would probably be fine because of the pool fixup). I also tagged the vault "transparent" so such disconnections will cause a veto in the future.


- Issue History
Date Modified Username Field Change
2014-12-06 22:37 Skrybe New Issue
2014-12-06 22:37 Skrybe File Added: Fierabras.cs
2014-12-23 20:10 neil Note Added: 0028140
2014-12-23 20:10 neil Status new => resolved
2014-12-23 20:10 neil Fixed in Branch => 0.16 development branch
2014-12-23 20:10 neil Resolution open => done
2014-12-23 20:10 neil Assigned To => neil
2014-12-23 20:11 neil Note Edited: 0028140
2015-05-19 17:49 Skrybe Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker