Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009283 [DCSS] Bug Report minor sometimes 2014-12-01 06:13 2015-02-25 00:13
Reporter geekosaur View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.16 ancient branch
Summary 0009283: (some?) runed door annotations not removed when seal broken
Description This has happened in two games so far; I am attaching the save from the latest. I also have a save from the earlier game, where it happened in the Zot vault on Depths:5 (the attached game is Lair:8). I would expect that, if I have opened the runed door, it is no longer runed and not annotated as such in the dungeon overview.

(This game also has the ambrosia bug, which has already been reported and fixed.)
Additional Information
Tags No tags attached.
Attached Files ? file icon u.cs [^] (592,550 bytes) 2014-12-01 06:13

- Relationships
has duplicate 0009399closedPleasingFungus Runed door annotations remain after opening 

-  Notes
(0027949)
geekosaur (reporter)
2014-12-01 06:16

Ok, I now know this is considered a "feature". Not a very useful one, it's just clutter, IMO.
(0028306)
elliptic (developer)
2015-01-19 16:23

Who considers this a "feature"? It seems like a clear bug to me - inconsistent with how other auto-annotations work and misleading to the player.
(0028308)
PleasingFungus (administrator)
2015-01-19 17:44

The context is 8374. I believe wheals' comment there has the reasoning for it not being automatically removed:

" I see your points about the difficulty of making it right in the case of multiple[-tile runed doors] / opened [doors], and it's probably good that the player can remove it, too. "
(0028319)
elliptic (developer)
2015-01-20 16:04

The fact that figuring out how to handle multiple-square doors is a little tricky doesn't make this less of a bug IMO. Players clearly expect the annotation to be removed, the annotation being removed was part of the original implementable, etc.

The current behavior is also pretty useless unless you carefully remove the annotation manually yourself each time you open a runed door -- if you finish Lair and then look through your ctrl-O to see what you might have left behind on past levels and see that D:5, D:8, and D:10 all have runed door annotations, you have to go and check the maps of each of those levels manually to see whether there really is a runed door.

I personally see the current behavior as worse than when runed doors were not autoannotated at all. In most cases it just clutters up your annotations with outdated information. If it is really too difficult to make it work properly (as everyone seems to expect it to work, as seen by the multiple bug reports), we should revert it.
(0028321)
chris (updater)
2015-01-20 16:19

Agreeing with elliptic that the current version is not as helpful for players as it could be. A possible short-term improvement was mentioned in the comments of 0008274 (clearing the annotations when the level is fully explored).
The ideal solution, to me, would be removing the annotation as soon as the seal is broken, and personally I'd be fine with minor information leaks related to multi-tile doors as well if that means the interface can be vastly improved.
(0028422)
wheals (administrator)
2015-02-02 21:14

Implemented in 0.16-a0-3903-gbdece4d. (Though I was too lazy to implement "X runed doors" rather than "X runed door".)
(0028564)
geekosaur (reporter)
2015-02-25 00:13

it's taken me this long to get a runed door to verify it...

- Issue History
Date Modified Username Field Change
2014-12-01 06:13 geekosaur New Issue
2014-12-01 06:13 geekosaur File Added: u.cs
2014-12-01 06:16 geekosaur Note Added: 0027949
2014-12-06 23:02 chris Issue Monitored: chris
2015-01-12 21:02 PleasingFungus Relationship added has duplicate 0009399
2015-01-19 16:23 elliptic Note Added: 0028306
2015-01-19 17:44 PleasingFungus Note Added: 0028308
2015-01-20 16:04 elliptic Note Added: 0028319
2015-01-20 16:19 chris Note Added: 0028321
2015-01-28 16:08 wheals Status new => assigned
2015-01-28 16:08 wheals Assigned To => wheals
2015-02-02 21:14 wheals Note Added: 0028422
2015-02-02 21:14 wheals Status assigned => resolved
2015-02-02 21:14 wheals Fixed in Branch => 0.16 development branch
2015-02-02 21:14 wheals Resolution open => done
2015-02-25 00:13 geekosaur Note Added: 0028564
2015-02-25 00:13 geekosaur Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker