Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009278 [DCSS] Bug Report minor always 2014-11-29 16:49 2014-12-06 16:58
Reporter Kvaak View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.16 ancient branch
Summary 0009278: Possibly weird interaction between distortion and Excrucating Wounds.
Description Casting EW while wielding a distortion weapon gives a warning. Upon confirmation you suffer a distortion effect even if you miscast EW. If succesful you can unwield the weapon without side effects as long as the pain brand lasts.

I can't find a commit that would seem to particularly target this behaviour but IIRC previously you could temporarily rebrand a distortion weapon without side effects, unwielding however would always cause disto effects.

Temporary rebrand causing disto effects seems inconsistent with ?brand weapon and the miscast unwield effect is particularly weird.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0027947)
wheals (administrator)
2014-12-01 01:15
edited on: 2014-12-01 01:15

http://s-z.org/neil/git/?p=crawl.git;a=commitdiff;h=ae2dc6209783 [^] makes the unwield effect occur after the miscast check (the prompt still comes before). It also adds a note to ?brand weapon's description that it does not cause an effect on rebrand.

Perhaps the effect happening on unwield would be better, but it was never the intended (or actual, AFAICT) behaviour at any point.


- Issue History
Date Modified Username Field Change
2014-11-29 16:49 Kvaak New Issue
2014-12-01 01:15 wheals Note Added: 0027947
2014-12-01 01:15 wheals Status new => resolved
2014-12-01 01:15 wheals Fixed in Branch => 0.16 development branch
2014-12-01 01:15 wheals Resolution open => done
2014-12-01 01:15 wheals Assigned To => wheals
2014-12-01 01:15 wheals Note Edited: 0027947
2014-12-06 16:58 Kvaak Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker